Re: [PATCH 1/5] perf metricgroup: Support printing metrics for arm64

From: John Garry
Date: Thu Mar 11 2021 - 03:50:51 EST


On 06/03/2021 19:34, Jiri Olsa wrote:
On Fri, Mar 05, 2021 at 11:06:58AM +0000, John Garry wrote:
Hi Jirka,

- struct pmu_events_map *map = perf_pmu__find_map(NULL);
+ struct pmu_events_map *map = find_cpumap();
so this is just for arm at the moment right?

Yes - but to be more accurate, arm64.

At the moment, from the archs which use pmu-events, only arm64 and nds32
have versions of get_cpuid_str() which require a non-NULL pmu argument.

But then apparently nds32 only supports a single CPU, so this issue of
heterogeneous CPUs should not be a concern there:)

could we rather make this arch specific code, so we don't need
to do the scanning on archs where this is not needed?

like marking perf_pmu__find_map as __weak and add arm specific
version?
Well I was thinking that this code should not be in metricgroup.c anyway.

So there is code which is common in current perf_pmu__find_map() for all
archs.

I could factor that out into a common function, below. Just a bit worried
about perf_pmu__find_map() and perf_pmu__find_pmu_map() being confused.
right, so perf_pmu__find_map does not take perf_pmu as argument
anymore, so the prefix does not fit, how about pmu_events_map__find ?

I just noticed this series:
https://lore.kernel.org/lkml/1612797946-18784-1-git-send-email-kan.liang@xxxxxxxxxxxxxxx/

Seems that this has metricgroup support for heterogeneous system config, while this series is metricgroup support for homogeneous system config for arch which supports heterogeneous system config. I need to check further for any conflicts.

@Kan Liang, it would be great if you could cc me on that series. I don't subscribe to the general list.

Thanks,
John