Re: [PATCH v5 08/16] rpmsg: glink: add sendto and trysendto ops

From: Mathieu Poirier
Date: Fri Mar 05 2021 - 11:56:01 EST


[...]

> >> }
> >>
> >> +static int qcom_glink_sendto(struct rpmsg_endpoint *ept, void *data, int len, u32 dst)
> >> +{
> >> + struct glink_channel *channel = to_glink_channel(ept);
> >> +
> >> + return __qcom_glink_send(channel, data, len, true);
> >> +}
> >> +
> >> +static int qcom_glink_trysendto(struct rpmsg_endpoint *ept, void *data, int len, u32 dst)
> >> +{
> >> + struct glink_channel *channel = to_glink_channel(ept);
> >> +
> >> + return __qcom_glink_send(channel, data, len, false);
> >> +}
> >
> > Just rename send() to sendto() and trysend() to trysendto() and ignore the
> > destination address.
>

Apologies for not being clear.

> Function prototypes have to match with rpmsg_endpoint_ops structure defined
> below. So seems to me not possible to just rename the functions.
> Please could you clarify if i missed something?

I don't think rproc_ops::send() and rproc_ops::trysend() are used anywhere else.
So replace them with rproc_ops::sendto() and rproc_ops::trysendto() where the
destination address would be ingnored.

>
> > The same goes for the next patch. I would fold patch 08
> > and 09 into 10 to help get the big picture.
>
> I'm going to squash all in one.

Perfect

>
> Thanks,
> Arnaud
>
> >
> >> +
> >> /*
> >> * Finds the device_node for the glink child interested in this channel.
> >> */
> >> @@ -1364,7 +1378,9 @@ static const struct rpmsg_device_ops glink_device_ops = {
> >> static const struct rpmsg_endpoint_ops glink_endpoint_ops = {
> >> .destroy_ept = qcom_glink_destroy_ept,
> >> .send = qcom_glink_send,
> >> + .sendto = qcom_glink_sendto,
> >> .trysend = qcom_glink_trysend,
> >> + .trysendto = qcom_glink_trysendto,
> >> };
> >>
> >> static void qcom_glink_rpdev_release(struct device *dev)
> >> --
> >> 2.17.1
> >>