Re: [PATCH V2 mips/linux.git] firmware: bcm47xx_nvram: refactor finding & reading NVRAM

From: Rafał Miłecki
Date: Fri Mar 05 2021 - 07:35:34 EST


On 05.03.2021 12:47, Philippe Mathieu-Daudé wrote:
On Fri, Mar 5, 2021 at 11:16 AM Rafał Miłecki <rafal@xxxxxxxxxx> wrote:
On 05.03.2021 10:58, Philippe Mathieu-Daudé wrote:
On Fri, Mar 5, 2021 at 6:55 AM Rafał Miłecki <zajec5@xxxxxxxxx> wrote:

From: Rafał Miłecki <rafal@xxxxxxxxxx>

1. Use meaningful variable names (e.g. "flash_start", "res_size" instead
of e.g. "iobase", "end")
2. Always operate on "offset" instead of mix of start, end, size, etc.

"instead of a mix"

3. Add helper checking for NVRAM to avoid duplicating code
4. Use "found" variable instead of goto
5. Use simpler checking of offsets and sizes (2 nested loops with
trivial check instead of extra function)

This could be a series of trivial patches, why did you choose to make a mixed
bag harder to review?

It's a subjective thing and often a matter of maintainer taste. I can
say that after contributing to various Linux subsystems. If you split a
similar patch for MTD subsystem you'll get complains about making
changes too small & too hard to review (sic!).

Fine. MTD subsystem developers are probably smarter than I'm :)

This isn't a bomb really: 63 insertions(+), 48 deletions(-)

Too many changes at once for my brain stack doesn't mean others are
willing to review it. But to me that means each time I'll have to pass over
it while bisecting or reviewing git history I'll suffer the same overflow.
Anyway, matter of taste as you said.

If I hear another voice for splitting this change into smaller patches
I'm 100% happy to do so. Honestly!

I just don't know if by splitting I won't annoy other people by making
changes too small.

Please speak up! :)