Re: [PATCH] certs: Fix wrong kconfig option used for x509_revocation_list

From: David Howells
Date: Wed Mar 03 2021 - 10:19:57 EST


Eric Snowberg <eric.snowberg@xxxxxxxxxx> wrote:

> +ifeq ($(CONFIG_SYSTEM_REVOCATION_LIST),y)
> +obj-$(CONFIG_SYSTEM_BLACKLIST_KEYRING) += revocation_certificates.o
> +endif

Should the ifeq be referring to CONFIG_SYSTEM_REVOCATION_KEYS rather than
CONFIG_SYSTEM_REVOCATION_LIST? In fact, since S_R_K depends indirectly on
S_B_K, you should be able to just do:

+obj-$(CONFIG_SYSTEM_REVOCATION_KEYS) += revocation_certificates.o

> +#ifdef CONFIG_SYSTEM_REVOCATION_LIST

Here also?

> + hostprogs-always-$(CONFIG_SYSTEM_BLACKLIST_KEYRING) += extract-cert

And here too?

(As an aside, I wonder if SYSTEM_REVOCATION_CERTS would be a better name, but
I'm okay with leaving it as-is for now).

David