Re: [PATCH] ACPI / APEI: Add is_ghes_type() to identify GHES sources

From: Terry Bowman
Date: Mon Jan 25 2021 - 17:45:12 EST


On 1/25/21 11:14 AM, Borislav Petkov wrote:
On Mon, Jan 25, 2021 at 05:41:04PM +0100, Rafael J. Wysocki wrote:
On Fri, Jan 22, 2021 at 7:05 PM Terry Bowman<terry.bowman@xxxxxxx> wrote:
From: Yazen Ghannam<yazen.ghannam@xxxxxxx>

Refactor duplicated GHES identity logic into is_ghes_type().

Signed-off-by: Yazen Ghannam<yazen.ghannam@xxxxxxx>
Reviewed-by: Robert Richter<rrichter@xxxxxxx>
Signed-off-by: Terry Bowman<terry.bowman@xxxxxxx>
If Terry was a co-author of the patch, please add a Co-developed-by:
tag for him in addition to the s-o-b. Otherwise the meaning of his
s-o-b is unclear.
I will add "co-developed-by" in V2.
Boris, James, any objections to the changes below?

---
drivers/acpi/apei/hest.c | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)

diff --git a/drivers/acpi/apei/hest.c b/drivers/acpi/apei/hest.c
index 6e980fe16772..bd702e0ef339 100644
--- a/drivers/acpi/apei/hest.c
+++ b/drivers/acpi/apei/hest.c
@@ -49,6 +49,12 @@ static const int hest_esrc_len_tab[ACPI_HEST_TYPE_RESERVED] = {
[ACPI_HEST_TYPE_IA32_DEFERRED_CHECK] = -1,
};

+static inline bool is_ghes_type(struct acpi_hest_header *hest_hdr)
+{
+ return hest_hdr->type == ACPI_HEST_TYPE_GENERIC_ERROR ||
+ hest_hdr->type == ACPI_HEST_TYPE_GENERIC_ERROR_V2;
I realize that this is supposed to test whether the table point to a
generic hardware error source but everything in our code pertaining to
GHES is called, well, "ghes".

So I'd prefer to call that is_generic_error() or so.
Sure, I'll rename is_ghes_type() to is_generic_error() in v2.
Thx.