[PATCH v5 00/18] Refactor generic_file_buffered_read

From: Matthew Wilcox (Oracle)
Date: Fri Jan 22 2021 - 11:05:12 EST


This is a combination of Christoph's work to refactor
generic_file_buffered_read() and some of my large-page support
which was disrupted by Kent's refactoring of generic_file_buffered_read.

v5:
- Rebase on next-20210122 (new conflict due to typo fix)
- Folded in Reviewed-bys
v4:
- Rebase on next-20210120
- Fix compilation error with pagevec_init & reinit
- Simplify filemap_range_uptodate() by passing pos instead of iocb
v3:
- Fixed missing put_page for readahead with IOCB_NOIO (hch)
- Fixed commit message for lock_page_for_iocb (nborisov)
v2:
- Added pagevec conversion upfront and rebased other patches on top of
it (me)
- Limit page search by max pgoff_t rather than by number of pages (me)
- Renamed mapping_get_read_thps() to filemap_get_read_batch() (hch/me)
- Added doc for filemap_get_read_batch() (hch/me)
- Removed 'first' parameter from filemap_update_page() (me)
- Folded "Remove parameters from filemap_update_page()" into an earlier
patch (hch)
- Restructured filemap_update_page() error handling flow (hch/me)
- Pass the pagevec to filemap_create_page() (hch)
- Renamed 'find_page' label to 'retry' (hch)
- Explicitly check for AOP_TRUNCATED_PAGE instead of assuming err > 0
means retry (hch)
- Move mark_page_accessed() and handling of i_size into main copy loop (me)

Christoph Hellwig (2):
mm/filemap: Rename generic_file_buffered_read to filemap_read
mm/filemap: Simplify generic_file_read_iter

Matthew Wilcox (Oracle) (16):
mm/filemap: Rename generic_file_buffered_read subfunctions
mm/filemap: Remove dynamically allocated array from filemap_read
mm/filemap: Convert filemap_get_pages to take a pagevec
mm/filemap: Use head pages in generic_file_buffered_read
mm/filemap: Pass a sleep state to put_and_wait_on_page_locked
mm/filemap: Support readpage splitting a page
mm/filemap: Inline __wait_on_page_locked_async into caller
mm/filemap: Don't call ->readpage if IOCB_WAITQ is set
mm/filemap: Change filemap_read_page calling conventions
mm/filemap: Change filemap_create_page calling conventions
mm/filemap: Convert filemap_update_page to return an errno
mm/filemap: Move the iocb checks into filemap_update_page
mm/filemap: Add filemap_range_uptodate
mm/filemap: Split filemap_readahead out of filemap_get_pages
mm/filemap: Restructure filemap_get_pages
mm/filemap: Don't relock the page after calling readpage

fs/btrfs/file.c | 2 +-
include/linux/fs.h | 4 +-
include/linux/pagemap.h | 3 +-
mm/filemap.c | 565 ++++++++++++++++++----------------------
mm/huge_memory.c | 4 +-
mm/migrate.c | 4 +-
6 files changed, 267 insertions(+), 315 deletions(-)

--
2.29.2