Re: [RFC PATCH v2] pinctrl: add helper to expose pinctrl state in debugfs

From: Drew Fustini
Date: Thu Jan 21 2021 - 00:58:35 EST


On Mon, Jan 11, 2021 at 12:03:18PM +0200, Tony Lindgren wrote:
> Hi,
>
> * Linus Walleij <linus.walleij@xxxxxxxxxx> [210109 21:14]:
> > On Sat, Jan 9, 2021 at 3:55 AM Drew Fustini <drew@xxxxxxxxxxxxxxx> wrote:
> >
> > > I discussed my use case and this patch on #armlinux earlier this week
> > > and Alexandre Belloni suggested looking at the pinmux-pins debugfs file.
> >
> > This sounds reasonable.
> >
> > > This made me think that a possible solution could be to define a store
> > > function for pinmux-pins to handle something like "<pin#> <function#>".
> > > I believe the ability to activate a pin function (or pin group) from
> > > userspace would satisfy our beagleboard.org use-case.
> > >
> > > Does that seem like a reasonable approach?
> >
> > This sounds like a good approach.
>
> Makes sense to me too.
>
> We may want to make it into a proper sysfs interface eventually to not
> require debugfs be enabled in .config. But that's another set of patches,
> certainly makes sense to first enable it for debugfs.
>
> Regards,
>
> Tony

I have added a debugfs file "pinmux-set" to pinmux.c. This allows
"<function-number> <group-number>" to be written into that file. The
function pinmux_set_write() calls ops->set_mux() with fsel and gsel.

I'll post an RFC with the code, but I am wondering if it would better
to take the function as a name and then lookup the function number
(fsel)?

thanks,
drew