Re: [PATCH v1 2/2] ACPI: scan: Adjust white space in acpi_device_add()

From: Hans de Goede
Date: Sat Jan 16 2021 - 07:38:18 EST


Hi,

On 1/14/21 7:47 PM, Rafael J. Wysocki wrote:
> From: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
>
> Add empty lines in some places in acpi_device_add() to help
> readability and drop leading spaces before the labels in there.
>
> No functional impact.
>
> Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>

Patch looks good to me:

Reviewed-by: Hans de Goede <hdegoede@xxxxxxxxxx>

Regards,

Hans



> ---
> drivers/acpi/scan.c | 9 +++++++--
> 1 file changed, 7 insertions(+), 2 deletions(-)
>
> Index: linux-pm/drivers/acpi/scan.c
> ===================================================================
> --- linux-pm.orig/drivers/acpi/scan.c
> +++ linux-pm/drivers/acpi/scan.c
> @@ -692,10 +692,12 @@ int acpi_device_add(struct acpi_device *
>
> if (device->wakeup.flags.valid)
> list_add_tail(&device->wakeup_list, &acpi_wakeup_device_list);
> +
> mutex_unlock(&acpi_device_lock);
>
> if (device->parent)
> device->dev.parent = &device->parent->dev;
> +
> device->dev.bus = &acpi_bus_type;
> device->dev.release = release;
> result = device_add(&device->dev);
> @@ -711,16 +713,19 @@ int acpi_device_add(struct acpi_device *
>
> return 0;
>
> - err:
> +err:
> mutex_lock(&acpi_device_lock);
> +
> if (device->parent)
> list_del(&device->node);
> +
> list_del(&device->wakeup_list);
>
> - err_unlock:
> +err_unlock:
> mutex_unlock(&acpi_device_lock);
>
> acpi_detach_data(device->handle, acpi_scan_drop_device);
> +
> return result;
> }
>
>
>
>