Re: [PATCH v2 1/3] spi: convert to BIT() all spi_device flags

From: Andy Shevchenko
Date: Tue Nov 24 2020 - 06:46:47 EST


On Tue, Nov 24, 2020 at 12:16 PM Alexandru Ardelean
<alexandru.ardelean@xxxxxxxxxx> wrote:
>
> This change converts all bit flags for the 'struct spi_device' mode to the
> BIT() macro. The change is mostly for readability. Since adding more bit
> fields, might as well convert it now.

...

#include <linux/bits.h>

And honestly I think the entire inclusion block with data type forward
declarations should be revisited here.

...

> +#define SPI_CPHA BIT(0) /* clock phase */
> +#define SPI_CPOL BIT(1) /* clock polarity */

--
With Best Regards,
Andy Shevchenko