Re: [PATCH 05/14] fs: don't allow kernel reads and writes without iter ops

From: Linus Torvalds
Date: Fri Oct 02 2020 - 12:27:33 EST


On Thu, Oct 1, 2020 at 3:41 PM Al Viro <viro@xxxxxxxxxxxxxxxxxx> wrote:
>
> Better
> loff_t dummy = 0;
> ...
> wr = __kernel_write(file, data, bytes, &dummy);

No, just fix __kernel_write() to work correctly.

The fact is, NULL _is_ the right pointer for ppos these days.

That commit by Christoph is buggy: it replaces new_sync_write() with a
buggy open-coded version.

Notice how new_sync_write does

kiocb.ki_pos = (ppos ? *ppos : 0);
,,,
if (ret > 0 && ppos)
*ppos = kiocb.ki_pos;

but the open-coded version doesn't.

So just fix that in linux-next. The *last* thing we want is to have
different semantics for the "same" kernel functions.

Linus