Re: [PATCH v2 2/6] can: dev: add a helper function

From: Marc Kleine-Budde
Date: Thu Oct 01 2020 - 11:51:47 EST


On 10/1/20 5:45 PM, Vincent Mailhol wrote:
>>> +static inline int get_can_len(struct sk_buff *skb)
>>
>> make this return an u8
>> make the skb const
>>
>>> +{
>>> + struct canfd_frame *cf =3D (struct canfd_frame *)skb->data;
>>
>> const
>>
>>> +
>>> + if (can_is_canfd_skb(skb))
>>> + return min_t(__u8, cf->len, CANFD_MAX_DLEN);
>>
>> u8
>>
>>> + else if (cf->can_id & CAN_RTR_FLAG)
>>> + return 0;
>>> + else
>>> + return min_t(__u8, cf->len, CAN_MAX_DLEN);
>>
>> u8
>
> Noted. All those changes will be addressed in v3 series.
> Thank you.
>
> As a side note, macros get_can_dlc() and get_canfd_dlc of the same
> file (include/linux/can/dev.h) also use __u8 instead of u8. Do you
> want me to add a patch to change these as below?

yes. looks good


tnx,
Marc

--
Pengutronix e.K. | Marc Kleine-Budde |
Embedded Linux | https://www.pengutronix.de |
Vertretung West/Dortmund | Phone: +49-231-2826-924 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |

Attachment: signature.asc
Description: OpenPGP digital signature