[PATCH v3 00/19] MHI changes for v5.10

From: Manivannan Sadhasivam
Date: Tue Sep 29 2020 - 13:52:35 EST


Hi Greg,

Here is the MHI series for v5.10 cycle. Most of the patches are cleanups
in the MHI stack. Notable changes are below:

* Saving the client device hardware information obtained through the BHI
protocol. This information will be exposed through sysfs to make use in
the userland applications.
* Introduce sysfs entries to read the serial number and OEM PK hash values
of the client device obtained from BHI protocol. Relevant API documentation
is also added.
* Introduce debugfs entries to show MHI states, events, channels, register
state etc... to aid debug.
* Remove the channel name from MHI device name as the device is not specific
to channels. Used generic names instead!
* Fix the warning reported by Kbuild bot by using append (+=) Kbuild rule
to the mhi/core Makefile.
* Introduce APIs to allocate and free MHI controllers. This is done to make
sure that the allocated structs are initialized to NULL before passing to
the MHI core.
* Remove the requirement to have a dedicated IRQ for each event ring.
The MHI controllers can now use a single IRQ for all event rings.

Please consider merging!

Thanks,
Mani

Changes in v2:

* Clubbed both series (take one and two) onto a single one
* Used dev_groups to manage sysfs attributes
* Merged the debugfs fix patch with the debugfs patch
* Dropped MAX_MTU patch for now

Changes in v3:

* Dropped below patches:
bus: mhi: Remove auto-start option
net: qrtr: Start MHI channels during init

Bhaumik Bhatt (12):
bus: mhi: core: Remove double occurrence for mhi_ctrl_ev_task()
declaration
bus: mhi: core: Abort suspends due to outgoing pending packets
bus: mhi: core: Use helper API to trigger a non-blocking host resume
bus: mhi: core: Trigger host resume if suspended during
mhi_device_get()
bus: mhi: core: Use generic name field for an MHI device
bus: mhi: core: Introduce helper function to check device state
bus: mhi: core: Introduce counters to track MHI device state
transitions
bus: mhi: core: Read and save device hardware information from BHI
bus: mhi: core: Introduce APIs to allocate and free the MHI controller
bus: mhi: Fix entries based on Kconfig coding style
bus: mhi: core: Introduce debugfs entries for MHI
bus: mhi: core: Introduce sysfs entries for MHI

Clark Williams (1):
bus: mhi: Remove include of rwlock_types.h

Hemant Kumar (1):
bus: mhi: core: Add const qualifier to MHI config information

Loic Poulain (3):
bus: mhi: core: Allow shared IRQ for event rings
bus: mhi: Remove unused nr_irqs_req variable
bus: mhi: debugfs: Print channel context read-pointer

Manivannan Sadhasivam (1):
bus: mhi: core: Fix the building of MHI module

Randy Dunlap (1):
bus: mhi: fix doubled words and struct image_info kernel-doc

Documentation/ABI/stable/sysfs-bus-mhi | 21 ++
MAINTAINERS | 1 +
drivers/bus/mhi/Kconfig | 20 +-
drivers/bus/mhi/core/Makefile | 3 +-
drivers/bus/mhi/core/boot.c | 17 +-
drivers/bus/mhi/core/debugfs.c | 411 +++++++++++++++++++++++++
drivers/bus/mhi/core/init.c | 87 +++++-
drivers/bus/mhi/core/internal.h | 37 ++-
drivers/bus/mhi/core/main.c | 27 +-
drivers/bus/mhi/core/pm.c | 28 +-
include/linux/mhi.h | 51 ++-
11 files changed, 639 insertions(+), 64 deletions(-)
create mode 100644 Documentation/ABI/stable/sysfs-bus-mhi
create mode 100644 drivers/bus/mhi/core/debugfs.c

--
2.17.1