Re: [PATCH] misc: fastrpc: add ioctl for attaching to sensors pd

From: Srinivas Kandagatla
Date: Mon Sep 07 2020 - 13:19:11 EST




On 07/09/2020 14:51, Jonathan Marek wrote:
@@ -1477,7 +1477,10 @@ static long fastrpc_device_ioctl(struct file *file, unsigned int cmd,
          err = fastrpc_invoke(fl, argp);
          break;
      case FASTRPC_IOCTL_INIT_ATTACH:
-        err = fastrpc_init_attach(fl);
+        err = fastrpc_init_attach(fl, 0);
+        break;
+    case FASTRPC_IOCTL_INIT_ATTACH_SNS:
+        err = fastrpc_init_attach(fl, 2);

Shouldn't you have #defines for those magic numbers somewhere?  What
does 0 and 2 mean?


This is based off a downstream driver which also uses magic numbers, although I can make an educated guess about the meaning.

Srini do you have any suggestions for how to name these values?

These are domain id corresponding to each core.
you can use SDSP_DOMAIN_ID in here!
these are already defined in the file as:

#define ADSP_DOMAIN_ID (0)
#define MDSP_DOMAIN_ID (1)
#define SDSP_DOMAIN_ID (2)
#define CDSP_DOMAIN_ID (3)


--srini