[PATCH v2 00/10] crypto: hisilicon/zip - misc clean up

From: Yang Shen
Date: Mon Sep 07 2020 - 04:24:35 EST


This patchset make some clean up:
patch 1:remove useless parameters
patch 4:replace 'sprintf' with 'scnprintf'
patch 7:fix static check warning
and the rest patch fix some coding style

v2:
- remove the return check of 'scnprintf' in PATCH 4

Shukun Tan (1):
crypto: hisilicon/zip - modify debugfs interface parameters

Yang Shen (9):
crypto: hisilicon/zip - remove some useless parameters
crypto: hisilicon/zip - unify naming style for functions and macros
crypto: hisilicon/zip - replace 'sprintf' with 'scnprintf'
crypto: hisilicon/zip - use a enum parameter instead of some macros
crypto: hisilicon/zip - add print for error branch
crypto: hisilicon/zip - fix static check warning
crypto: hisilicon/zip - move some private macros from 'zip.h' to
'zip_crypto.c'
crypto: hisilicon/zip - supplement some comments
crypto: hisilicon/zip - fix some coding styles

drivers/crypto/hisilicon/zip/zip.h | 15 ----
drivers/crypto/hisilicon/zip/zip_crypto.c | 112 ++++++++++++++++++--------
drivers/crypto/hisilicon/zip/zip_main.c | 126 ++++++++++++++----------------
3 files changed, 135 insertions(+), 118 deletions(-)

--
2.7.4