[PATCH v2] udf: Use kvzalloc() in udf_sb_alloc_bitmap()

From: Denis Efremov
Date: Thu Aug 27 2020 - 17:28:14 EST


Use kvzalloc() in udf_sb_alloc_bitmap() instead of open-coding it.
Size computation wrapped in struct_size() macro to prevent potential
integer overflows.

Signed-off-by: Denis Efremov <efremov@xxxxxxxxx>
---
fs/udf/super.c | 9 ++-------
1 file changed, 2 insertions(+), 7 deletions(-)

diff --git a/fs/udf/super.c b/fs/udf/super.c
index 1c42f544096d..bdf51bea54f3 100644
--- a/fs/udf/super.c
+++ b/fs/udf/super.c
@@ -1010,14 +1010,9 @@ static struct udf_bitmap *udf_sb_alloc_bitmap(struct super_block *sb, u32 index)
int size;

nr_groups = udf_compute_nr_groups(sb, index);
- size = sizeof(struct udf_bitmap) +
- (sizeof(struct buffer_head *) * nr_groups);
-
- if (size <= PAGE_SIZE)
- bitmap = kzalloc(size, GFP_KERNEL);
- else
- bitmap = vzalloc(size); /* TODO: get rid of vzalloc */
+ size = struct_size(bitmap, s_block_bitmap, nr_groups);

+ bitmap = kvzalloc(size, GFP_KERNEL);
if (!bitmap)
return NULL;

--
2.26.2