Re: [PATCH 2/8] mm: Use find_get_swap_page in memcontrol

From: Matthew Wilcox
Date: Thu Aug 27 2020 - 09:05:03 EST


On Wed, Aug 26, 2020 at 10:20:02AM -0400, Johannes Weiner wrote:
> The refactor makes sense to me, but the name is confusing. We're not
> looking for a swap page, we're primarily looking for a file page in
> the page cache mapping that's handed in. Only in the special case
> where it's a shmem mapping and there is a swap entry do we consult the
> auxiliary swap cache.
>
> How about find_get_page_or_swapcache()? find_get_page_shmemswap()?
> Maybe you have a better idea. It's a fairly specialized operation that
> isn't widely used, so a longer name isn't a bad thing IMO.

Got it. find_get_incore_page(). I was going to go with inmem, but that
it matches mincore sold me on it.

/**
* find_get_incore_page - Find and get a page from the page or swap caches.
* @mapping: The address_space to search.
* @index: The page cache index.
*
* This differs from find_get_page() in that it will also look for the
* page in the swap cache.
*
* Return: The found page or %NULL.
*/

I was focusing too much on what the function did, not why it was doing it.