Re: [PATCH v4 3/4] phy: mediatek: Move mtk_hdmi_phy driver into drivers/phy/mediatek folder

From: Chun-Kuang Hu
Date: Thu Aug 20 2020 - 19:31:34 EST


Hi, Sam:

Sam Ravnborg <sam@xxxxxxxxxxxx> 於 2020年8月20日 週四 上午12:04寫道:
>
> Hi Chun-Kuang
>
> Two small details below.
>
> Sam
>
> On Wed, Aug 19, 2020 at 11:44:20PM +0800, Chun-Kuang Hu wrote:
> > From: CK Hu <ck.hu@xxxxxxxxxxxx>
> >
> > mtk_hdmi_phy is currently placed inside mediatek drm driver, but it's
> > more suitable to place a phy driver into phy driver folder, so move
> > mtk_hdmi_phy driver into phy driver folder.
> >
> > Signed-off-by: CK Hu <ck.hu@xxxxxxxxxxxx>
> > Signed-off-by: Chun-Kuang Hu <chunkuang.hu@xxxxxxxxxx>
> > Reviewed-by: Chunfeng Yun <chunfeng.yun@xxxxxxxxxxxx>
> > Reviewed-by: Matthias Brugger <matthias.bgg@xxxxxxxxx>
> > ---
> > drivers/gpu/drm/mediatek/Kconfig | 7 -------
> > drivers/gpu/drm/mediatek/Makefile | 6 ------
> > drivers/phy/mediatek/Kconfig | 7 +++++++
> > drivers/phy/mediatek/Makefile | 6 ++++++
> > .../mediatek/phy-mtk-hdmi-mt2701.c} | 2 +-
> > .../mediatek/phy-mtk-hdmi-mt8173.c} | 2 +-
> > .../mtk_hdmi_phy.c => phy/mediatek/phy-mtk-hdmi.c} | 2 +-
> > .../mtk_hdmi_phy.h => phy/mediatek/phy-mtk-hdmi.h} | 0
> > 8 files changed, 16 insertions(+), 16 deletions(-)
> > rename drivers/{gpu/drm/mediatek/mtk_mt2701_hdmi_phy.c => phy/mediatek/phy-mtk-hdmi-mt2701.c} (99%)
> > rename drivers/{gpu/drm/mediatek/mtk_mt8173_hdmi_phy.c => phy/mediatek/phy-mtk-hdmi-mt8173.c} (99%)
> > rename drivers/{gpu/drm/mediatek/mtk_hdmi_phy.c => phy/mediatek/phy-mtk-hdmi.c} (99%)
> > rename drivers/{gpu/drm/mediatek/mtk_hdmi_phy.h => phy/mediatek/phy-mtk-hdmi.h} (100%)
> >
> > diff --git a/drivers/gpu/drm/mediatek/Kconfig b/drivers/gpu/drm/mediatek/Kconfig
> > index ca3cd871a350..65cd03a4be29 100644
> > --- a/drivers/gpu/drm/mediatek/Kconfig
> > +++ b/drivers/gpu/drm/mediatek/Kconfig
> > @@ -27,10 +27,3 @@ config DRM_MEDIATEK_HDMI
> > select PHY_MTK_HDMI
> > help
> > DRM/KMS HDMI driver for Mediatek SoCs
> > -
> > -config PHY_MTK_HDMI
> > - tristate "MediaTek HDMI-PHY Driver"
> > - depends on ARCH_MEDIATEK && OF
> > - select GENERIC_PHY
> > - help
> > - Enable this to support HDMI-PHY
> > diff --git a/drivers/gpu/drm/mediatek/Makefile b/drivers/gpu/drm/mediatek/Makefile
> > index fcbef23aa6ce..77b0fd86063d 100644
> > --- a/drivers/gpu/drm/mediatek/Makefile
> > +++ b/drivers/gpu/drm/mediatek/Makefile
> > @@ -22,9 +22,3 @@ mediatek-drm-hdmi-objs := mtk_cec.o \
> > mtk_hdmi_ddc.o
> >
> > obj-$(CONFIG_DRM_MEDIATEK_HDMI) += mediatek-drm-hdmi.o
> > -
> > -phy-mtk-hdmi-drv-objs := mtk_hdmi_phy.o \
> > - mtk_mt2701_hdmi_phy.o \
> > - mtk_mt8173_hdmi_phy.o
> > -
> > -obj-$(CONFIG_PHY_MTK_HDMI) += phy-mtk-hdmi-drv.o
> > diff --git a/drivers/phy/mediatek/Kconfig b/drivers/phy/mediatek/Kconfig
> > index dee757c957f2..10f0ec2d5b54 100644
> > --- a/drivers/phy/mediatek/Kconfig
> > +++ b/drivers/phy/mediatek/Kconfig
> > @@ -35,3 +35,10 @@ config PHY_MTK_XSPHY
> > Enable this to support the SuperSpeedPlus XS-PHY transceiver for
> > USB3.1 GEN2 controllers on MediaTek chips. The driver supports
> > multiple USB2.0, USB3.1 GEN2 ports.
> > +
> > +config PHY_MTK_HDMI
> > + tristate "MediaTek HDMI-PHY Driver"
> > + depends on ARCH_MEDIATEK && OF
> > + select GENERIC_PHY
> > + help
> > + Enable this to support HDMI-PHY
> This helptext could use a bit more love and care - it is not obvious
> from the help text what this option does.
>

OK, would add more detail information.

>
> > diff --git a/drivers/phy/mediatek/Makefile b/drivers/phy/mediatek/Makefile
> > index 08a8e6a97b1e..c9a3641f0b16 100644
> > --- a/drivers/phy/mediatek/Makefile
> > +++ b/drivers/phy/mediatek/Makefile
> > @@ -6,3 +6,9 @@
> > obj-$(CONFIG_PHY_MTK_TPHY) += phy-mtk-tphy.o
> > obj-$(CONFIG_PHY_MTK_UFS) += phy-mtk-ufs.o
> > obj-$(CONFIG_PHY_MTK_XSPHY) += phy-mtk-xsphy.o
> > +
> > +phy-mtk-hdmi-drv-objs := phy-mtk-hdmi.o \
> > + phy-mtk-hdmi-mt2701.o \
> > + phy-mtk-hdmi-mt8173.o
> > +
> The modern syntax is to use -y and not -objs.
> And getting rid of '\' would also be nice.
> So something like this:
>
> phy-mtk-hdmi-drv-y := phy-mtk-hdmi.o
> phy-mtk-hdmi-drv-y += phy-mtk-hdmi-mt2701.o
> phy-mtk-hdmi-drv-y += phy-mtk-hdmi-mt8173.o
>
> Looks much more readable to me.
>

OK,

Regards,
Chun-Kuang.

> > +obj-$(CONFIG_PHY_MTK_HDMI) += phy-mtk-hdmi-drv.o
> > diff --git a/drivers/gpu/drm/mediatek/mtk_mt2701_hdmi_phy.c b/drivers/phy/mediatek/phy-mtk-hdmi-mt2701.c
> > similarity index 99%
> > rename from drivers/gpu/drm/mediatek/mtk_mt2701_hdmi_phy.c
> > rename to drivers/phy/mediatek/phy-mtk-hdmi-mt2701.c
> > index 99fe05cd3598..a6cb1dea3d0c 100644
> > --- a/drivers/gpu/drm/mediatek/mtk_mt2701_hdmi_phy.c
> > +++ b/drivers/phy/mediatek/phy-mtk-hdmi-mt2701.c
> > @@ -4,7 +4,7 @@
> > * Author: Chunhui Dai <chunhui.dai@xxxxxxxxxxxx>
> > */
> >
> > -#include "mtk_hdmi_phy.h"
> > +#include "phy-mtk-hdmi.h"
> >
> > #define HDMI_CON0 0x00
> > #define RG_HDMITX_DRV_IBIAS 0
> > diff --git a/drivers/gpu/drm/mediatek/mtk_mt8173_hdmi_phy.c b/drivers/phy/mediatek/phy-mtk-hdmi-mt8173.c
> > similarity index 99%
> > rename from drivers/gpu/drm/mediatek/mtk_mt8173_hdmi_phy.c
> > rename to drivers/phy/mediatek/phy-mtk-hdmi-mt8173.c
> > index 827b93786fac..6cdfdf5a698a 100644
> > --- a/drivers/gpu/drm/mediatek/mtk_mt8173_hdmi_phy.c
> > +++ b/drivers/phy/mediatek/phy-mtk-hdmi-mt8173.c
> > @@ -4,7 +4,7 @@
> > * Author: Jie Qiu <jie.qiu@xxxxxxxxxxxx>
> > */
> >
> > -#include "mtk_hdmi_phy.h"
> > +#include "phy-mtk-hdmi.h"
> >
> > #define HDMI_CON0 0x00
> > #define RG_HDMITX_PLL_EN BIT(31)
> > diff --git a/drivers/gpu/drm/mediatek/mtk_hdmi_phy.c b/drivers/phy/mediatek/phy-mtk-hdmi.c
> > similarity index 99%
> > rename from drivers/gpu/drm/mediatek/mtk_hdmi_phy.c
> > rename to drivers/phy/mediatek/phy-mtk-hdmi.c
> > index fe022acddbef..8fc83f01a720 100644
> > --- a/drivers/gpu/drm/mediatek/mtk_hdmi_phy.c
> > +++ b/drivers/phy/mediatek/phy-mtk-hdmi.c
> > @@ -4,7 +4,7 @@
> > * Author: Jie Qiu <jie.qiu@xxxxxxxxxxxx>
> > */
> >
> > -#include "mtk_hdmi_phy.h"
> > +#include "phy-mtk-hdmi.h"
> >
> > static int mtk_hdmi_phy_power_on(struct phy *phy);
> > static int mtk_hdmi_phy_power_off(struct phy *phy);
> > diff --git a/drivers/gpu/drm/mediatek/mtk_hdmi_phy.h b/drivers/phy/mediatek/phy-mtk-hdmi.h
> > similarity index 100%
> > rename from drivers/gpu/drm/mediatek/mtk_hdmi_phy.h
> > rename to drivers/phy/mediatek/phy-mtk-hdmi.h
> > --
> > 2.17.1
> >
> > _______________________________________________
> > dri-devel mailing list
> > dri-devel@xxxxxxxxxxxxxxxxxxxxx
> > https://lists.freedesktop.org/mailman/listinfo/dri-devel