Re: alternative to xa_for_each?

From: Matthew Wilcox
Date: Wed Jul 01 2020 - 10:37:38 EST


On Wed, Jul 01, 2020 at 07:02:39AM +0100, Christoph Hellwig wrote:
> Hi Matthew,
>
> I'm just reviewing a patch adding an xarray user, and I'm wondering
> if we could just replace xa_for_each with a loop on
> xa_find_after with a magic index to start from the beginning? That
> would always seem like more readable code than the magic looping macro.

The problem is that there is no index we can use for that purpose.
xa_find_after(0) should return the entry at 1 (or higher).
xa_find_after(ULONG_MAX) should return NULL. The xas_ version doesn't
have this problem because we can distinguish between "first time" and
"subsequent time" by values in the xa_state.

> And while we're at it: is there an idiomatic way to get the entry with
> the highest index?

That's something I need to add. I think I did it once but then the user
went away.