[PATCH v2 0/2] gpio: aggregator: Misc parsing improvements

From: Geert Uytterhoeven
Date: Wed Jul 01 2020 - 07:42:25 EST


Hi Linus, Bartosz, Andy,

This patch series contains two improvements for the parsing code in the
GPIO Aggregator.

The second one converts the driver to use bitmap_parselist() for parsing
GPIO offsets and/or ranges, as suggested by Andy[1]. This should have
no impact on the format of the configuration parameters written to the
"new_device" virtual file in sysfs.

Changes compared to v1:
- Rename mask to bitmap,
- Allocate bitmap dynamically.

Thanks for your comments!

[1] https://lore.kernel.org/r/20200520121420.GA1867563@xxxxxxxxxxxxxxxxxx

Geert Uytterhoeven (2):
gpio: aggregator: Drop pre-initialization in get_arg()
gpio: aggregator: Use bitmap_parselist() for parsing GPIO offsets

drivers/gpio/gpio-aggregator.c | 63 +++++++++++++++-------------------
1 file changed, 28 insertions(+), 35 deletions(-)

--
2.17.1

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds