Re: [PATCH v8 04/13] perf stat: factor out body of event handling loop for system wide

From: Alexey Budankov
Date: Thu Jun 25 2020 - 12:01:33 EST



On 25.06.2020 15:17, Jiri Olsa wrote:
> On Wed, Jun 24, 2020 at 05:27:41PM +0300, Alexey Budankov wrote:
>>
>> On 23.06.2020 17:56, Jiri Olsa wrote:
>>> On Wed, Jun 17, 2020 at 11:37:43AM +0300, Alexey Budankov wrote:
>>>>
>>>> Introduce process_timeout() and process_interval() functions that
>>>> factor out body of event handling loop for attach and system wide
>>>> monitoring use cases.
>>>>
>>>> Signed-off-by: Alexey Budankov <alexey.budankov@xxxxxxxxxxxxxxx>
>>>> ---
>>>> tools/perf/builtin-stat.c | 28 ++++++++++++++++++++--------
>>>> 1 file changed, 20 insertions(+), 8 deletions(-)
>>>>
>>>> diff --git a/tools/perf/builtin-stat.c b/tools/perf/builtin-stat.c
>>>> index 9be020e0098a..31f7ccf9537b 100644
>>>> --- a/tools/perf/builtin-stat.c
>>>> +++ b/tools/perf/builtin-stat.c
>>>> @@ -475,6 +475,23 @@ static void process_interval(void)
>>>> print_counters(&rs, 0, NULL);
>>>> }
>>>>
>>>> +static bool print_interval(unsigned int interval, int *times)
>>>> +{
>>>> + if (interval) {
>>>> + process_interval();
>>>> + if (interval_count && !(--(*times)))
>>>> + return true;
>>>> + }
>>>> + return false;
>>>> +}
>>>> +
>>>> +static bool process_timeout(int timeout, unsigned int interval, int *times)
>>>> +{
>>>> + if (timeout)
>>>> + return true;
>>>> + return print_interval(interval, times);
>>>> +}
>>>
>>> I think it's confusing to keep this together, that
>>> process_timeout triggers also interval processing
>>>
>>> I think you can keep the timeout separated from interval
>>> processing and rename the print_interval to process_interval
>>> and process_interval to __process_interval
>>
>> Well, ok.
>>
>> I will rename process_interval() to __process_interval() and
>> then print_interval() to process_interval().
>>
>> Regarding timeout let's have it like this:
>>
>> static bool process_timeout(int timeout)
>> {
>> return timeout ? true : false;
>> }
>
> can't this just stay as value check after finished poll?
>
> if (timeout)
> break;
>
> and then separate call to process_interval(interval, times)?

Like this? Still makes sense to have it in a single function.

static bool process_timing_settings(int timeout, unsigned int interval, int *times)
{
bool res = timeout ? true : false;
if (!res)
res = process_interval(interval, times);
return res;
}

~Alexey