Re: [PATCH 3/3] rcu/trace: Add name of the source for gp_seq to prevent confusion

From: Joel Fernandes
Date: Thu Jun 18 2020 - 22:07:26 EST


On Thu, Jun 18, 2020 at 09:36:41PM -0400, Joel Fernandes (Google) wrote:
[...]
> @@ -2019,7 +2019,7 @@ static int __noreturn rcu_gp_kthread(void *unused)
> cond_resched_tasks_rcu_qs();
> WRITE_ONCE(rcu_state.gp_activity, jiffies);
> WARN_ON(signal_pending(current));
> - trace_rcu_grace_period(rcu_state.name, rcu_state.gp_seq,
> + trace_rcu_grace_period(rcu_state.name, TPS("rsp"), rcu_state.gp_seq,
> TPS("reqwaitsig"));
> }
>
> @@ -2263,7 +2263,7 @@ int rcutree_dying_cpu(unsigned int cpu)
> return 0;
>
> blkd = !!(rnp->qsmask & rdp->grpmask);
> - trace_rcu_grace_period(rcu_state.name, READ_ONCE(rnp->gp_seq),
> + trace_rcu_grace_period(rcu_state.name, TPS("rsp"), READ_ONCE(rnp->gp_seq),

This should be: TPS("rnp") :-(

Happy to fix it up and resend if you'd like. Thanks!