Re: [PATCH 1/2] integrity: Add errno field in audit message

From: Steve Grubb
Date: Tue Jun 16 2020 - 16:29:08 EST


On Tuesday, June 16, 2020 3:53:40 PM EDT Mimi Zohar wrote:
> On Tue, 2020-06-16 at 11:55 -0400, Steve Grubb wrote:
> > On Tuesday, June 16, 2020 11:43:31 AM EDT Lakshmi Ramasubramanian wrote:
> > > On 6/16/20 8:29 AM, Steve Grubb wrote:
> > > >>>>> The idea is a good idea, but you're assuming that "result" is
> > > >>>>> always errno. That was probably true originally, but isn't now.
> > > >>>>> For example, ima_appraise_measurement() calls xattr_verify(),
> > > >>>>> which compares the security.ima hash with the calculated file
> > > >>>>> hash. On failure, it returns the result of memcmp(). Each and
> > > >>>>> every code path will need to be checked.
> > > >>>>
> > > >>>> Good catch Mimi.
> > > >>>>
> > > >>>> Instead of "errno" should we just use "result" and log the value
> > > >>>> given in the result parameter?
> > > >>>
> > > >>> That would likely collide with another field of the same name which
> > > >>> is the operation's results. If it really is errno, the name is fine.
> > > >>> It's generic enough that it can be reused on other events if that
> > > >>> mattered.
> > > >>
> > > >> Steve, what is the historical reason why we have both "res" and
> > > >> "result" for indicating a boolean success/fail? I'm just curious
> > > >> how we ended up this way, and who may still be using "result".
> > > >
> > > > I think its pam and some other user space things did this. But
> > > > because of mixed machines in datacenters supporting multiple versions
> > > > of OS, we have to leave result alone. It has to be 0,1 or success/
> > > > fail. We cannot use it for errno.
> > >
> > > As Mimi had pointed out, since the value passed in result parameter is
> > > not always an error code, "errno" is not an appropriate name.
> > >
> > > Can we add a new field, say, "op_result" to report the result of the
> > > specified operation?
> >
> > Sure. But since it is errno sometimes, how would we know when to
> > translate it?
>
> Perhaps the solution is not to imply "res" is "errno", but pass it as
> a separate "errno" field.

That's what is done on syscalls. There is success and exit where they both
have different meaning sometimes but otherwise they agree.

> Then only include "errno" in the audit message when it isn't zero. This
> assumes that some audit messages for the same audit number include errno,
> while others do not.

We normally do not like to have fields that swing in and out because then its
hard to know exactly what's in the event. When an event has different fields
under special conditions, then we just say call it a new event. Split it into
2 or 3 instead forcing it all into 1. And we also do not like fields that
change meaning. Because then intepretation becomes hard. Or other people
wishing to record the same info in another event have to follow the same
pattern.

So, if you really need this field, the give some name like err_code or errno
or anything not taken. And just fill it out every time. Its OK to be 0. If
this only happens under some special operation, then make it a new event and
fill it out only for that operation/event.

Best Regards,
-Steve


> With this solution, the existing integrity_audit_msg() could become a
> wrapper for the new function.
>
> Mimi