[PATCH rdma-next 00/10] Various clean ups to ib_cm

From: Leon Romanovsky
Date: Wed May 06 2020 - 03:47:08 EST


From: Leon Romanovsky <leonro@xxxxxxxxxxxx>

>From Jason,

These are intended to be no-functional change edits that tidy up the
code flow or coding style.

Thanks

Danit Goldberg (1):
RDMA/cm: Remove unused store to ret in cm_rej_handler

Jason Gunthorpe (9):
RDMA/addr: Mark addr_resolve as might_sleep()
RDMA/cm: Remove return code from add_cm_id_to_port_list
RDMA/cm: Pull duplicated code into cm_queue_work_unlock()
RDMA/cm: Pass the cm_id_private into cm_cleanup_timewait
RDMA/cm: Add a note explaining how the timewait is eventually freed
RDMA/cm: Make find_remote_id() return a cm_id_private
RDMA/cm: Remove the cm_free_id() wrapper function
RDMA/cm: Remove needless cm_id variable
RDMA/cm: Increment the refcount inside cm_find_listen()

drivers/infiniband/core/addr.c | 4 +
drivers/infiniband/core/cm.c | 239 +++++++++++----------------------
2 files changed, 85 insertions(+), 158 deletions(-)

--
2.26.2