Re: [PATCH 2/3] objtool: Rename elf_read() to elf_open_read()

From: Matt Helsley
Date: Wed Apr 22 2020 - 13:00:50 EST


On Wed, Apr 22, 2020 at 04:22:35PM +0200, Ingo Molnar wrote:
>
> * Peter Zijlstra <peterz@xxxxxxxxxxxxx> wrote:
>
> > On Wed, Apr 22, 2020 at 12:32:04PM +0200, Ingo Molnar wrote:
> > > 'struct elf *' handling is an open/close paradigm, make sure the naming
> > > matches that:
> > >
> > > elf_open_read()
> > > elf_write()
> > > elf_close()
> >
> >
> > > diff --git a/tools/objtool/check.c b/tools/objtool/check.c
> > > index f2a84271e807..12e2aea42bb2 100644
> > > --- a/tools/objtool/check.c
> > > +++ b/tools/objtool/check.c
> > > @@ -2614,7 +2614,7 @@ int check(const char *_objname, bool orc)
> > >
> > > objname = _objname;
> > >
> > > - file.elf = elf_read(objname, orc ? O_RDWR : O_RDONLY);
> > > + file.elf = elf_open_read(objname, orc ? O_RDWR : O_RDONLY);
> >
> > Note that I have a patch pending that makes that unconditionally O_RDWR,
> > which sort of seems to suggest elf_open() might be the better name.
>
> Ok, done!

It might be a better name but there could be a problem with it --
see 8e144797f1a67c52e386161863da4614a23ad913
"objtool: Rename elf_open() to prevent conflict with libelf from elftoolchain"

Unless I'm forgetting something I think that'd still be an issue.

Cheers,
-Matt