[PATCH v3 1/6] usb: musb: Use USB_DIR_IN when calling musb_advance_schedule()

From: matwey . kornilov
Date: Tue Apr 21 2020 - 09:30:54 EST


From: "Matwey V. Kornilov" <matwey@xxxxxxxxxx>

Use USB_DIR_IN instead of 1 when calling musb_advance_schedule().
This is consistent with the rest of musb_host.c code and impoves
the readability.

Signed-off-by: Matwey V. Kornilov <matwey@xxxxxxxxxx>
---
drivers/usb/musb/musb_host.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/usb/musb/musb_host.c b/drivers/usb/musb/musb_host.c
index 8736f4251a22..b0614c59e0e5 100644
--- a/drivers/usb/musb/musb_host.c
+++ b/drivers/usb/musb/musb_host.c
@@ -1169,7 +1169,7 @@ irqreturn_t musb_h_ep0_irq(struct musb *musb)

/* call completion handler if done */
if (complete)
- musb_advance_schedule(musb, urb, hw_ep, 1);
+ musb_advance_schedule(musb, urb, hw_ep, USB_DIR_IN);
done:
return retval;
}
--
2.25.0