Re: [PATCH v2 5/7] remoteproc: Restructure firmware name allocation

From: Suman Anna
Date: Fri Apr 17 2020 - 09:39:43 EST


Hi Markus,

On 4/16/20 1:26 AM, Markus Elfring wrote:
â
+++ b/drivers/remoteproc/remoteproc_core.c
@@ -1984,14 +1984,14 @@ static int rproc_alloc_firmware(struct rproc *rproc,
{
const char *p;

- if (!firmware)
+ if (firmware)
+ p = kstrdup_const(firmware, GFP_KERNEL);
+ else
/*
* If the caller didn't pass in a firmware name then
* construct a default name.
*/
p = kasprintf(GFP_KERNEL, "rproc-%s-fw", name);
- else
- p = kstrdup_const(firmware, GFP_KERNEL);

Can the use of the conditional operator make sense at such source code places?

p = firmware ? kstrdup_const(â) : kasprintf(â);

For simple assignments, I too prefer the ternary operator, but in this case, I think it is better to leave the current code as is.

regards
Suman