Re: [PATCH] mmc: sd: use HIGH_SPEED_BUS_SPEED in mmc_sd_switch_hs()

From: Ulf Hansson
Date: Fri Apr 17 2020 - 07:29:47 EST


On Fri, 10 Apr 2020 at 08:57, Jisheng Zhang <Jisheng.Zhang@xxxxxxxxxxxxx> wrote:
>
> Use the well defined HIGH_SPEED_BUS_SPEED macro in mmc_sd_switch_hs()
> to make code more readable.
>
> Signed-off-by: Jisheng Zhang <Jisheng.Zhang@xxxxxxxxxxxxx>

Applied for next, thanks!

Kind regards
Uffe


> ---
> drivers/mmc/core/sd.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/mmc/core/sd.c b/drivers/mmc/core/sd.c
> index 76c7add367d5..43de3190d718 100644
> --- a/drivers/mmc/core/sd.c
> +++ b/drivers/mmc/core/sd.c
> @@ -376,11 +376,11 @@ int mmc_sd_switch_hs(struct mmc_card *card)
> if (!status)
> return -ENOMEM;
>
> - err = mmc_sd_switch(card, 1, 0, 1, status);
> + err = mmc_sd_switch(card, 1, 0, HIGH_SPEED_BUS_SPEED, status);
> if (err)
> goto out;
>
> - if ((status[16] & 0xF) != 1) {
> + if ((status[16] & 0xF) != HIGH_SPEED_BUS_SPEED) {
> pr_warn("%s: Problem switching card into high-speed mode!\n",
> mmc_hostname(card->host));
> err = 0;
> --
> 2.26.0
>