Re:Re: [PATCH] serial: pl011: format long message string into lines

From: çæè
Date: Fri Mar 13 2020 - 03:36:55 EST


From: Jiri Slaby <jslaby@xxxxxxx>
Date: 2020-03-13 15:03:05
To: WANG Wenhu <wenhu.wang@xxxxxxxx>,Russell King <linux@xxxxxxxxxxxxxxx>,Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx>,linux-serial@xxxxxxxxxxxxxxx,linux-kernel@xxxxxxxxxxxxxxx
Cc: trivial@xxxxxxxxxx
Subject: Re: [PATCH] serial: pl011: format long message string into lines>On 13. 03. 20, 7:56, WANG Wenhu wrote:
>> Separate the message string into lines for pl011_probe_dt_alias()
>> to make it better comply with kernel coding style, and also, make
>> it more readable.
>>
>> It would still be grep friendly for the separated format.
>>
>> Signed-off-by: WANG Wenhu <wenhu.wang@xxxxxxxx>
>> ---
>> drivers/tty/serial/amba-pl011.c | 3 ++-
>> 1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/tty/serial/amba-pl011.c b/drivers/tty/serial/amba-pl011.c
>> index 2296bb0f9578..e693b7ac5a3a 100644
>> --- a/drivers/tty/serial/amba-pl011.c
>> +++ b/drivers/tty/serial/amba-pl011.c
>> @@ -2523,7 +2523,8 @@ static int pl011_probe_dt_alias(int index, struct device *dev)
>> }
>>
>> if (seen_dev_with_alias && seen_dev_without_alias)
>> - dev_warn(dev, "aliased and non-aliased serial devices found in device tree. Serial port enumeration may be unpredictable.\n");
>> + dev_warn(dev, "aliased and non-aliased serial devices found in device tree." \
>> + "Serial port enumeration may be unpredictable.\n");
>
>1) You removed a space after the dot
>2) the backslash is superfluous
>3) CodingStyle clearly states:
>"""
>However, never break user-visible strings such as
>printk messages, because that breaks the ability to grep for them.
>"""
>
>So, sorry:
>Nacked-by: Jiri Slaby <jslaby@xxxxxxx>
>
Surely, sorry for my fault. Out to reference coding style once more in detail.
Thanks.
>>
>> return ret;
>> }
>>
>
>
>--
>js
>suse labs

Wenhu