RE: [PATCH v3 5/5] platform/x86: intel_pmc_core: fix: Make pmc_core_lpm_display() generic for platforms that support sub-states

From: Kammela, Gayatri
Date: Mon Mar 02 2020 - 13:57:10 EST


> -----Original Message-----
> From: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> Sent: Monday, March 2, 2020 4:54 AM
> To: Kammela, Gayatri <gayatri.kammela@xxxxxxxxx>
> Cc: platform-driver-x86@xxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx;
> Somayaji, Vishwanath <vishwanath.somayaji@xxxxxxxxx>;
> dvhart@xxxxxxxxxxxxx; Westerberg, Mika <mika.westerberg@xxxxxxxxx>;
> peterz@xxxxxxxxxxxxx; Prestopine, Charles D
> <charles.d.prestopine@xxxxxxxxx>; Chen Zhou <chenzhou10@xxxxxxxxxx>;
> Box, David E <david.e.box@xxxxxxxxx>
> Subject: Re: [PATCH v3 5/5] platform/x86: intel_pmc_core: fix: Make
> pmc_core_lpm_display() generic for platforms that support sub-states
>
> On Sun, Mar 01, 2020 at 12:44:26PM -0800, Gayatri Kammela wrote:
> > Currently pmc_core_lpm_display() uses array of struct pointers i.e.,
> > tgl_lpm_maps for Tiger Lake directly to iterate through and to get the
> > number of status/live status registers which is hardcoded and cannot
> > be re-used for future platforms that support sub-states. To maintain
> > readability, make pmc_core_lpm_display() generic, so that it can
> > re-used for future platforms.
>
> My comments below.

Thanks Andy! for the comments.

>
> ...
>
> > +static int pmc_core_lpm_get_arr_size(const struct pmc_bit_map **maps)
> > +{
> > + int idx, arr_size = 0;
>
> And why do you need arr_size variable at all?

I could just return idx value at the end of the for loop. I will remove the arr_size variable.

>
> > +
> > + for (idx = 0; maps[idx]; idx++)
> > + arr_size++;
> > +
> > + return arr_size;
> > +}
>
> ...
>
> > - int index, idx, len = 32, bit_mask;
> > + int index, idx, bit_mask, len = 32;
>
> What's the point of shuffling this?

Just wanted to have all uninitialized variables declared before initialized ones. I will just leave this out in v4.

>
> > + int arr_size = pmc_core_lpm_get_arr_size(maps);
>
> This would be better in a split manner, i.e.
>
> int arr_size;
>
> ...
>
> arr_size = ...;

Sure, I will make this change in v4

>
> ...
>
> > + lpm_regs = kmalloc_array(arr_size, sizeof(*lpm_regs), GFP_KERNEL);
> > + if(!lpm_regs)
>
> > + goto err;
>
> There is no point to have the label. Simple return will work.

Thought adding a label will help not to have multiple kfree() in the same function (one here at the check and one at the end of the for loop) I will add a return.

>
> > - for (index = 0; tgl_lpm_maps[index]; index++) {
> > + for (index = 0; maps[index]; index++) {
>
> Why not to reuse arr_size here?

Good point! I missed it. I will use the arr_size here to iterate.

>
> > lpm_regs[index] = pmc_core_reg_read(pmcdev, offset);
> > offset += 4;
> > }
>
> --
> With Best Regards,
> Andy Shevchenko
>