Re: [PATCH 1/2] kvm: vmx: Use basic exit reason to check if it's the specific VM EXIT

From: Xiaoyao Li
Date: Thu Feb 27 2020 - 03:35:27 EST


On 2/27/2020 7:59 AM, Sean Christopherson wrote:
On Tue, Feb 25, 2020 at 02:41:20PM +0800, Xiaoyao Li wrote:
On 2/25/2020 2:13 PM, Sean Christopherson wrote:
On Tue, Feb 25, 2020 at 08:13:15AM +0800, Xiaoyao Li wrote:
On 2/25/2020 12:17 AM, Sean Christopherson wrote:
I have thought about union, but it seems

union {
u16 exit_reason;
u32 full_exit_reason;
}

is not a good name. Since there are many codes in vmx.c and nested.c assume
that exit_reason stands for 32-bit EXIT REASON vmcs field as well as
evmcs->vm_exit_reason and vmcs12->vm_exit_reason. Do we really want to also
rename them to full_exit_reason?

It's actually the opposite, almost all of the VMX code assumes exit_reason
holds only the basic exit reason, i.e. a 16-bit value. For example, SGX
adds a modifier flag to denote a VM-Exit was from enclave mode, and that
bit needs to be stripped from exit_reason, otherwise all the checks like
"if (exit_reason == blah_blah_blah)" fail.

Making exit_reason a 16-bit alias of the full/extended exit_reason neatly
sidesteps that issue. And it is an issue that has caused actual problems
in the past, e.g. see commit beb8d93b3e42 ("KVM: VMX: Fix handling of #MC
that occurs during VM-Entry"). Coincidentally, that commit also removes a
local "u16 basic_exit_reason" :-).

Except for one mistake, the pseudo-patch below is the entirety of required
changes. Most (all?) of the functions that take "u32 exit_reason" can (and
should) continue to take a u32.

As for the name, I strongly prefer keeping the exit_reason name for the
basic exit reason. The vast majority of VM-Exits do not have modifiers
set, i.e. "basic exit reason" == vmcs.EXIT_REASON for nearly all normal
usage. This holds true in every form of communication, e.g. when discussing
VM-Exit reasons, it's never qualified with "basic", it's simply the exit
reason. IMO the code is better off following the colloquial usage of "exit
reason". A simple comment above the union would suffice to clear up any
confusion with respect to the SDM.

Well, for this reason we can keep exit_reason for 16-bit usage, and define
full/extended_exit_reason for 32-bit cases. This makes less code churn.

But after we choose to use exit_reason and full/extended_exit_reason, what
if someday new modifier flags are added and we want to enable some modifier
flags for nested case?
I guess we need to change existing exit_reason to full/extended_exit_reason
in nested.c/nested.h to keep the naming rule consistent.

Ah, good point. But, that's just another bug in my psuedo patch :-)
It's literally one call site that needs to be updated. E.g.

if (is_guest_mode(vcpu) && nested_vmx_exit_reflected(vcpu, exit_reason))
return nested_vmx_reflect_vmexit(vcpu, full_exit_reason);


shouldn't we also pass full_exit_reason to nested_vmx_exit_reflected()?

Everywhere else KVM calls nested_vmx_reflect_vmexit() is (currently) done

I guess you wanted to say nested_vmx_vmexit() not nested_vmx_reflect_vmexit() here.

with a hardcoded value (except handle_vmfunc(), but I actually want to
change that one).