Re: [PATCH v6 6/9] drivers/base/power: add dpm_sysfs_change_owner()

From: Rafael J. Wysocki
Date: Tue Feb 25 2020 - 11:13:25 EST


On Tue, Feb 25, 2020 at 2:22 PM Christian Brauner
<christian.brauner@xxxxxxxxxx> wrote:
>
> Add a helper to change the owner of a device's power entries. This
> needs to happen when the ownership of a device is changed, e.g. when
> moving network devices between network namespaces.
> This function will be used to correctly account for ownership changes,
> e.g. when moving network devices between network namespaces.
>
> Signed-off-by: Christian Brauner <christian.brauner@xxxxxxxxxx>

Reviewed-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>

> ---
> /* v2 */
> - "Rafael J. Wysocki" <rafael@xxxxxxxxxx>:
> - Fold if (dev->power.wakeup && dev->power.wakeup->dev) check into
> if (device_can_wakeup(dev)) check since the former can never be true if
> the latter is false.
>
> - Christian Brauner <christian.brauner@xxxxxxxxxx>:
> - Place (dev->power.wakeup && dev->power.wakeup->dev) check under
> CONFIG_PM_SLEEP ifdefine since it will wakeup_source will only be available
> when this config option is set.
>
> /* v3 */
> - Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx>:
> - Add explicit uid/gid parameters.
>
> /* v4 */
> - "Rafael J. Wysocki" <rafael@xxxxxxxxxx>:
> - Remove in-function #ifdef in favor of separate helper that is a nop
> whenver !CONFIG_PM_SLEEP.
>
> /* v5 */
> - "Rafael J. Wysocki" <rafael@xxxxxxxxxx>:
> - Return directly if condition is true in dpm_sysfs_wakeup_change_owner()
> instead of using additional variable.
>
> /* v6 */
> - Christian Brauner <christian.brauner@xxxxxxxxxx>:
> - Make dpm_sysfs_wakeup_change_owner() static inline.
> ---
> drivers/base/core.c | 4 +++
> drivers/base/power/power.h | 3 +++
> drivers/base/power/sysfs.c | 55 +++++++++++++++++++++++++++++++++++++-
> 3 files changed, 61 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/base/core.c b/drivers/base/core.c
> index 988f34ce2eb0..fb8b7990f6fd 100644
> --- a/drivers/base/core.c
> +++ b/drivers/base/core.c
> @@ -3552,6 +3552,10 @@ int device_change_owner(struct device *dev, kuid_t kuid, kgid_t kgid)
> if (error)
> goto out;
>
> + error = dpm_sysfs_change_owner(dev, kuid, kgid);
> + if (error)
> + goto out;
> +
> #ifdef CONFIG_BLOCK
> if (sysfs_deprecated && dev->class == &block_class)
> goto out;
> diff --git a/drivers/base/power/power.h b/drivers/base/power/power.h
> index 444f5c169a0b..54292cdd7808 100644
> --- a/drivers/base/power/power.h
> +++ b/drivers/base/power/power.h
> @@ -74,6 +74,7 @@ extern int pm_qos_sysfs_add_flags(struct device *dev);
> extern void pm_qos_sysfs_remove_flags(struct device *dev);
> extern int pm_qos_sysfs_add_latency_tolerance(struct device *dev);
> extern void pm_qos_sysfs_remove_latency_tolerance(struct device *dev);
> +extern int dpm_sysfs_change_owner(struct device *dev, kuid_t kuid, kgid_t kgid);
>
> #else /* CONFIG_PM */
>
> @@ -88,6 +89,8 @@ static inline void pm_runtime_remove(struct device *dev) {}
>
> static inline int dpm_sysfs_add(struct device *dev) { return 0; }
> static inline void dpm_sysfs_remove(struct device *dev) {}
> +static inline int dpm_sysfs_change_owner(struct device *dev, kuid_t kuid,
> + kgid_t kgid) { return 0; }
>
> #endif
>
> diff --git a/drivers/base/power/sysfs.c b/drivers/base/power/sysfs.c
> index d7d82db2e4bc..2b99fe1eb207 100644
> --- a/drivers/base/power/sysfs.c
> +++ b/drivers/base/power/sysfs.c
> @@ -480,6 +480,14 @@ static ssize_t wakeup_last_time_ms_show(struct device *dev,
> return enabled ? sprintf(buf, "%lld\n", msec) : sprintf(buf, "\n");
> }
>
> +static inline int dpm_sysfs_wakeup_change_owner(struct device *dev, kuid_t kuid,
> + kgid_t kgid)
> +{
> + if (dev->power.wakeup && dev->power.wakeup->dev)
> + return device_change_owner(dev->power.wakeup->dev, kuid, kgid);
> + return 0;
> +}
> +
> static DEVICE_ATTR_RO(wakeup_last_time_ms);
>
> #ifdef CONFIG_PM_AUTOSLEEP
> @@ -501,7 +509,13 @@ static ssize_t wakeup_prevent_sleep_time_ms_show(struct device *dev,
>
> static DEVICE_ATTR_RO(wakeup_prevent_sleep_time_ms);
> #endif /* CONFIG_PM_AUTOSLEEP */
> -#endif /* CONFIG_PM_SLEEP */
> +#else /* CONFIG_PM_SLEEP */
> +static inline int dpm_sysfs_wakeup_change_owner(struct device *dev, kuid_t kuid,
> + kgid_t kgid)
> +{
> + return 0;
> +}
> +#endif
>
> #ifdef CONFIG_PM_ADVANCED_DEBUG
> static ssize_t runtime_usage_show(struct device *dev,
> @@ -684,6 +698,45 @@ int dpm_sysfs_add(struct device *dev)
> return rc;
> }
>
> +int dpm_sysfs_change_owner(struct device *dev, kuid_t kuid, kgid_t kgid)
> +{
> + int rc;
> +
> + if (device_pm_not_required(dev))
> + return 0;
> +
> + rc = sysfs_group_change_owner(&dev->kobj, &pm_attr_group, kuid, kgid);
> + if (rc)
> + return rc;
> +
> + if (pm_runtime_callbacks_present(dev)) {
> + rc = sysfs_group_change_owner(
> + &dev->kobj, &pm_runtime_attr_group, kuid, kgid);
> + if (rc)
> + return rc;
> + }
> +
> + if (device_can_wakeup(dev)) {
> + rc = sysfs_group_change_owner(&dev->kobj, &pm_wakeup_attr_group,
> + kuid, kgid);
> + if (rc)
> + return rc;
> +
> + rc = dpm_sysfs_wakeup_change_owner(dev, kuid, kgid);
> + if (rc)
> + return rc;
> + }
> +
> + if (dev->power.set_latency_tolerance) {
> + rc = sysfs_group_change_owner(
> + &dev->kobj, &pm_qos_latency_tolerance_attr_group, kuid,
> + kgid);
> + if (rc)
> + return rc;
> + }
> + return 0;
> +}
> +
> int wakeup_sysfs_add(struct device *dev)
> {
> return sysfs_merge_group(&dev->kobj, &pm_wakeup_attr_group);
> --
> 2.25.1
>