Re: [PATCH v3 2/2] driver core: Make deferred_probe_timeout global so it can be shared

From: Greg Kroah-Hartman
Date: Wed Feb 19 2020 - 02:57:34 EST


On Tue, Feb 18, 2020 at 10:07:48PM +0000, John Stultz wrote:
> --- a/include/linux/device/driver.h
> +++ b/include/linux/device/driver.h
> @@ -236,6 +236,7 @@ driver_find_device_by_acpi_dev(struct device_driver *drv, const void *adev)
> }
> #endif
>
> +extern int deferred_probe_timeout;
> void driver_deferred_probe_add(struct device *dev);

If this is going to be global now, can you rename it to
"driver_defferred_probe_timeout" to make it more in line with the other
exported symbols here?

thanks,

greg k-h