Re: [PATCH v6 00/19] Change readahead API

From: John Hubbard
Date: Tue Feb 18 2020 - 15:49:38 EST


On 2/17/20 10:45 AM, Matthew Wilcox wrote:
> From: "Matthew Wilcox (Oracle)" <willy@xxxxxxxxxxxxx>
>
> This series adds a readahead address_space operation to eventually
> replace the readpages operation. The key difference is that
> pages are added to the page cache as they are allocated (and
> then looked up by the filesystem) instead of passing them on a
> list to the readpages operation and having the filesystem add
> them to the page cache. It's a net reduction in code for each
> implementation, more efficient than walking a list, and solves
> the direct-write vs buffered-read problem reported by yu kuai at
> https://lore.kernel.org/linux-fsdevel/20200116063601.39201-1-yukuai3@xxxxxxxxxx/
>
> The only unconverted filesystems are those which use fscache.
> Their conversion is pending Dave Howells' rewrite which will make the
> conversion substantially easier.

Hi Matthew,

I see that Dave Chinner is reviewing this series, but I'm trying out his recent
advice about code reviews [1], and so I'm not going to read his comments first.
So you may see some duplication or contradictions this time around.


[1] Somewhere in this thread, "[LSF/MM/BPF TOPIC] FS Maintainers Don't Scale":
https://lore.kernel.org/r/20200131052520.GC6869@magnolia


thanks,
--
John Hubbard
NVIDIA

>
> v6:
> - Name the private members of readahead_control with a leading underscore
> (suggested by Christoph Hellwig)
> - Fix whitespace in rst file
> - Remove misleading comment in btrfs patch
> - Add readahead_next() API and use it in iomap
> - Add iomap_readahead kerneldoc.
> - Fix the mpage_readahead kerneldoc
> - Make various readahead functions return void
> - Keep readahead_index() and readahead_offset() pointing to the start of
> this batch through the body. No current user requires this, but it's
> less surprising.
> - Add kerneldoc for page_cache_readahead_limit
> - Make page_idx an unsigned long, and rename it to just 'i'
> - Get rid of page_offset local variable
> - Add patch to call memalloc_nofs_save() before allocating pages (suggested
> by Michal Hocko)
> - Resplit a lot of patches for more logical progression and easier review
> (suggested by John Hubbard)
> - Added sign-offs where received, and I deemed still relevant
>
> v5 switched to passing a readahead_control struct (mirroring the
> writepages_control struct passed to writepages). This has a number of
> advantages:
> - It fixes a number of bugs in various implementations, eg forgetting to
> increment 'start', an off-by-one error in 'nr_pages' or treating 'start'
> as a byte offset instead of a page offset.
> - It allows us to change the arguments without changing all the
> implementations of ->readahead which just call mpage_readahead() or
> iomap_readahead()
> - Figuring out which pages haven't been attempted by the implementation
> is more natural this way.
> - There's less code in each implementation.
>
> Matthew Wilcox (Oracle) (19):
> mm: Return void from various readahead functions
> mm: Ignore return value of ->readpages
> mm: Use readahead_control to pass arguments
> mm: Rearrange readahead loop
> mm: Remove 'page_offset' from readahead loop
> mm: rename readahead loop variable to 'i'
> mm: Put readahead pages in cache earlier
> mm: Add readahead address space operation
> mm: Add page_cache_readahead_limit
> fs: Convert mpage_readpages to mpage_readahead
> btrfs: Convert from readpages to readahead
> erofs: Convert uncompressed files from readpages to readahead
> erofs: Convert compressed files from readpages to readahead
> ext4: Convert from readpages to readahead
> f2fs: Convert from readpages to readahead
> fuse: Convert from readpages to readahead
> iomap: Restructure iomap_readpages_actor
> iomap: Convert from readpages to readahead
> mm: Use memalloc_nofs_save in readahead path
>
> Documentation/filesystems/locking.rst | 6 +-
> Documentation/filesystems/vfs.rst | 13 ++
> drivers/staging/exfat/exfat_super.c | 7 +-
> fs/block_dev.c | 7 +-
> fs/btrfs/extent_io.c | 46 ++-----
> fs/btrfs/extent_io.h | 3 +-
> fs/btrfs/inode.c | 16 +--
> fs/erofs/data.c | 39 ++----
> fs/erofs/zdata.c | 29 ++--
> fs/ext2/inode.c | 10 +-
> fs/ext4/ext4.h | 3 +-
> fs/ext4/inode.c | 23 ++--
> fs/ext4/readpage.c | 22 ++-
> fs/ext4/verity.c | 35 +----
> fs/f2fs/data.c | 50 +++----
> fs/f2fs/f2fs.h | 5 +-
> fs/f2fs/verity.c | 35 +----
> fs/fat/inode.c | 7 +-
> fs/fuse/file.c | 46 +++----
> fs/gfs2/aops.c | 23 ++--
> fs/hpfs/file.c | 7 +-
> fs/iomap/buffered-io.c | 118 +++++++----------
> fs/iomap/trace.h | 2 +-
> fs/isofs/inode.c | 7 +-
> fs/jfs/inode.c | 7 +-
> fs/mpage.c | 38 ++----
> fs/nilfs2/inode.c | 15 +--
> fs/ocfs2/aops.c | 34 ++---
> fs/omfs/file.c | 7 +-
> fs/qnx6/inode.c | 7 +-
> fs/reiserfs/inode.c | 8 +-
> fs/udf/inode.c | 7 +-
> fs/xfs/xfs_aops.c | 13 +-
> fs/zonefs/super.c | 7 +-
> include/linux/fs.h | 2 +
> include/linux/iomap.h | 3 +-
> include/linux/mpage.h | 4 +-
> include/linux/pagemap.h | 90 +++++++++++++
> include/trace/events/erofs.h | 6 +-
> include/trace/events/f2fs.h | 6 +-
> mm/internal.h | 8 +-
> mm/migrate.c | 2 +-
> mm/readahead.c | 184 +++++++++++++++++---------
> 43 files changed, 474 insertions(+), 533 deletions(-)
>
>
> base-commit: 11a48a5a18c63fd7621bb050228cebf13566e4d8
>