Re: [PATCH net-next] net: page_pool: API cleanup and comments

From: David Miller
Date: Sun Feb 16 2020 - 23:00:01 EST


From: David Miller <davem@xxxxxxxxxxxxx>
Date: Sun, 16 Feb 2020 19:53:00 -0800 (PST)

> From: Ilias Apalodimas <ilias.apalodimas@xxxxxxxxxx>
> Date: Sun, 16 Feb 2020 11:40:55 +0200
>
>> Functions starting with __ usually indicate those which are exported,
>> but should not be called directly. Update some of those declared in the
>> API and make it more readable.
>>
>> page_pool_unmap_page() and page_pool_release_page() were doing
>> exactly the same thing. Keep the page_pool_release_page() variant
>> and export it in order to show up on perf logs.
>> Finally rename __page_pool_put_page() to page_pool_put_page() since we
>> can now directly call it from drivers and rename the existing
>> page_pool_put_page() to page_pool_put_full_page() since they do the same
>> thing but the latter is trying to sync the full DMA area.
>>
>> Also update netsec, mvneta and stmmac drivers which use those functions.
>>
>> Suggested-by: Jonathan Lemon <jonathan.lemon@xxxxxxxxx>
>> Signed-off-by: Ilias Apalodimas <ilias.apalodimas@xxxxxxxxxx>
>
> Applied to net-next, thanks.

Actually this doesn't compile, please respin:

drivers/net/ethernet/socionext/netsec.c: In function ʽnetsec_uninit_pkt_dringʼ:
drivers/net/ethernet/socionext/netsec.c:1201:4: error: too few arguments to function ʽpage_pool_put_pageʼ
page_pool_put_page(dring->page_pool, page, false);
^~~~~~~~~~~~~~~~~~
In file included from drivers/net/ethernet/socionext/netsec.c:17:
./include/net/page_pool.h:172:6: note: declared here
void page_pool_put_page(struct page_pool *pool, struct page *page,
^~~~~~~~~~~~~~~~~~