RE: [RFC PATCH v10 0/9] Enable ptp_kvm for arm/arm64

From: Jianyong Wu
Date: Sun Feb 16 2020 - 21:29:15 EST


Hi,
As this version change a lot, expect more comments. thanks.

Thanks
Jianyong
> -----Original Message-----
> From: Jianyong Wu <jianyong.wu@xxxxxxx>
> Sent: Monday, February 10, 2020 4:49 PM
> To: netdev@xxxxxxxxxxxxxxx; yangbo.lu@xxxxxxx; john.stultz@xxxxxxxxxx;
> tglx@xxxxxxxxxxxxx; pbonzini@xxxxxxxxxx; sean.j.christopherson@xxxxxxxxx;
> maz@xxxxxxxxxx; richardcochran@xxxxxxxxx; Mark Rutland
> <Mark.Rutland@xxxxxxx>; will@xxxxxxxxxx; Suzuki Poulose
> <Suzuki.Poulose@xxxxxxx>; Steven Price <Steven.Price@xxxxxxx>
> Cc: linux-kernel@xxxxxxxxxxxxxxx; linux-arm-kernel@xxxxxxxxxxxxxxxxxxx;
> kvmarm@xxxxxxxxxxxxxxxxxxxxx; kvm@xxxxxxxxxxxxxxx; Steve Capper
> <Steve.Capper@xxxxxxx>; Kaly Xin <Kaly.Xin@xxxxxxx>; Justin He
> <Justin.He@xxxxxxx>; Jianyong Wu <Jianyong.Wu@xxxxxxx>; nd
> <nd@xxxxxxx>
> Subject: [RFC PATCH v10 0/9] Enable ptp_kvm for arm/arm64
>
> kvm ptp targets to provide high precision time sync between guest and host
> in virtualization environment. Here, we enable kvm ptp for arm64.
>
> change log:
> from v10 to v9
> (1) change code base to v5.5.
> (2) enable ptp_kvm both for arm32 and arm64.
> (3) let user choose which of virtual counter or physical counter should
> return when using crosstimestamp mode of ptp_kvm for arm/arm64.
> (4) extend input argument for getcrosstimestamp API.
>
> from v8 to v9:
> (1) move ptp_kvm.h to driver/ptp/
> (2) replace license declaration of ptp_kvm.h the same with other header
> files in the same directory.
>
> from v7 to v8:
> (1) separate adding clocksource id for arm_arch_counter as a single
> patch.
> (2) update commit message for patch 4/8.
> (3) refine patch 7/8 and patch 8/8 to make them more independent.
>
> from v6 to v7:
> (1) include the omitted clocksource_id.h in last version.
> (2) reorder the header file in patch.
> (3) refine some words in commit message to make it more impersonal.
>
> from v5 to v6:
> (1) apply Mark's patch[4] to get SMCCC conduit.
> (2) add mechanism to recognize current clocksource by add
> clocksouce_id value into struct clocksource instead of method in patch-v5.
> (3) rename kvm_arch_ptp_get_clock_fn into
> kvm_arch_ptp_get_crosststamp.
>
> from v4 to v5:
> (1) remove hvc delay compensasion as it should leave to userspace.
> (2) check current clocksource in hvc call service.
> (3) expose current clocksource by adding it to system_time_snapshot.
> (4) add helper to check if clocksource is arm_arch_counter.
> (5) rename kvm_ptp.c to ptp_kvm_common.c
>
> from v3 to v4:
> (1) fix clocksource of ptp_kvm to arch_sys_counter.
> (2) move kvm_arch_ptp_get_clock_fn into arm_arch_timer.c
> (3) subtract cntvoff before return cycles from host.
> (4) use ktime_get_snapshot instead of getnstimeofday and
> get_current_counterval to return time and counter value.
> (5) split ktime and counter into two 32-bit block respectively to avoid
> Y2038-safe issue.
> (6) set time compensation to device time as half of the delay of hvc call.
> (7) add ARM_ARCH_TIMER as dependency of ptp_kvm for arm64.
>
> from v2 to v3:
> (1) fix some issues in commit log.
> (2) add some receivers in send list.
>
> from v1 to v2:
> (1) move arch-specific code from arch/ to driver/ptp/
> (2) offer mechanism to inform userspace if ptp_kvm service is available.
> (3) separate ptp_kvm code for arm64 into hypervisor part and guest part.
> (4) add API to expose monotonic clock and counter value.
> (5) refine code: remove no necessary part and reconsitution.
>
>
> Jianyong Wu (8):
> psci: export psci conduit get helper.
> ptp: Reorganize ptp_kvm modules to make it arch-independent.
> clocksource: Add clocksource id for arm arch counter
> psci: Add hypercall service for ptp_kvm.
> ptp: arm/arm64: Enable ptp_kvm for arm/arm64
> ptp: extend input argument for getcrosstimestamp API
> arm/arm64: add mechanism to let user choose which counter to return
> arm/arm64: Add kvm capability check extension for ptp_kvm
>
> Thomas Gleixner (1):
> time: Add mechanism to recognize clocksource in time_get_snapshot
>
> drivers/clocksource/arm_arch_timer.c | 33 ++++++++
> drivers/firmware/psci/psci.c | 1 +
> drivers/net/ethernet/intel/e1000e/ptp.c | 3 +-
> drivers/ptp/Kconfig | 2 +-
> drivers/ptp/Makefile | 5 ++
> drivers/ptp/ptp_chardev.c | 8 +-
> drivers/ptp/ptp_kvm.h | 11 +++
> drivers/ptp/ptp_kvm_arm.c | 53 +++++++++++++
> drivers/ptp/{ptp_kvm.c => ptp_kvm_common.c} | 83 ++++++--------------
> drivers/ptp/ptp_kvm_x86.c | 87 +++++++++++++++++++++
> include/linux/arm-smccc.h | 21 +++++
> include/linux/clocksource.h | 6 ++
> include/linux/clocksource_ids.h | 13 +++
> include/linux/ptp_clock_kernel.h | 3 +-
> include/linux/timekeeping.h | 12 +--
> include/uapi/linux/kvm.h | 1 +
> include/uapi/linux/ptp_clock.h | 4 +-
> kernel/time/clocksource.c | 3 +
> kernel/time/timekeeping.c | 1 +
> virt/kvm/arm/arm.c | 1 +
> virt/kvm/arm/hypercalls.c | 44 ++++++++++-
> 21 files changed, 323 insertions(+), 72 deletions(-) create mode 100644
> drivers/ptp/ptp_kvm.h create mode 100644 drivers/ptp/ptp_kvm_arm.c
> rename drivers/ptp/{ptp_kvm.c => ptp_kvm_common.c} (60%) create mode
> 100644 drivers/ptp/ptp_kvm_x86.c create mode 100644
> include/linux/clocksource_ids.h
>
> --
> 2.17.1