Re: [PATCH v2 1/2] Bluetooth: hci_qca: Enable clocks required for BT SOC

From: gubbaven
Date: Wed Feb 05 2020 - 05:38:11 EST


Hi Bjorn,

On 2020-02-04 14:34, Marcel Holtmann wrote:
Hi Bjorn,

Instead of relying on other subsytem to turn ON clocks
required for BT SoC to operate, voting them from the driver.

Signed-off-by: Venkata Lakshmi Narayana Gubba <gubbaven@xxxxxxxxxxxxxx>
---
v2:
* addressed forward declarations
* updated with devm_clk_get_optional()

---
drivers/bluetooth/hci_qca.c | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

diff --git a/drivers/bluetooth/hci_qca.c b/drivers/bluetooth/hci_qca.c
index d6e0c99..73706f3 100644
--- a/drivers/bluetooth/hci_qca.c
+++ b/drivers/bluetooth/hci_qca.c
@@ -1738,6 +1738,15 @@ static int qca_power_off(struct hci_dev *hdev)
return 0;
}

+static int qca_setup_clock(struct clk *clk, bool enable)
+{
+ if (enable)
+ return clk_prepare_enable(clk);
+
+ clk_disable_unprepare(clk);
+ return 0;
+}

As Marcel requested, inline these.

+
static int qca_regulator_enable(struct qca_serdev *qcadev)
{
struct qca_power *power = qcadev->bt_power;
@@ -1755,6 +1764,13 @@ static int qca_regulator_enable(struct qca_serdev *qcadev)

power->vregs_on = true;

+ ret = qca_setup_clock(qcadev->susclk, true);
+ if (ret) {
+ /* Turn off regulators to overcome power leakage */

You can omit this comment as well, as the name of the function you call
is aptly named.
[Venkata] :
We will update in next patch set.

+ qca_regulator_disable(qcadev);
+ return ret;

Just return ret below instead.
[Venkata] :
We will update in next patch set

+ }
+
return 0;
}

@@ -1773,6 +1789,9 @@ static void qca_regulator_disable(struct qca_serdev *qcadev)

regulator_bulk_disable(power->num_vregs, power->vreg_bulk);
power->vregs_on = false;
+
+ if (qcadev->susclk)

In the enable path you (correctly) rely on passing NULL to the clock
code, so do the same here.
[Venkata] :
We will update in next patch set.

I already pushed the patch, but I am happy to accept a cleanup patch.

Regards

Marcel

Regards,
Venkata.