Re: [PATCH v3 2/5] ACPI: Add a convenience function to tell a device is suspended in probe

From: Rafael J. Wysocki
Date: Tue Jan 21 2020 - 11:03:13 EST


On Tue, Jan 21, 2020 at 10:09 AM Sakari Ailus
<sakari.ailus@xxxxxxxxxxxxxxx> wrote:
>
> Hi Rafael,
>
> Thank you for the review.
>
> On Mon, Jan 13, 2020 at 11:41:12AM +0100, Rafael J. Wysocki wrote:
> > On Thu, Jan 9, 2020 at 4:44 PM Sakari Ailus
> > <sakari.ailus@xxxxxxxxxxxxxxx> wrote:
> > >
> > > Add a convenience function to tell whether a device is suspended for probe
> > > or remove, for busses where the custom is that drivers don't need to
> > > resume devices in probe, or suspend them in their remove handlers.
> > >
> > > Returns false on non-ACPI systems.
> > >
> > > Suggested-by: Mika Westerberg <mika.westerberg@xxxxxxxxxxxxxxx>
> > > Signed-off-by: Sakari Ailus <sakari.ailus@xxxxxxxxxxxxxxx>
> > > ---
> > > drivers/acpi/device_pm.c | 35 +++++++++++++++++++++++++++++++++++
> > > include/linux/acpi.h | 5 +++++
> > > 2 files changed, 40 insertions(+)
> > >
> > > diff --git a/drivers/acpi/device_pm.c b/drivers/acpi/device_pm.c
> > > index 5e4a8860a9c0c..87393020276d8 100644
> > > --- a/drivers/acpi/device_pm.c
> > > +++ b/drivers/acpi/device_pm.c
> > > @@ -1348,4 +1348,39 @@ int acpi_dev_pm_attach(struct device *dev, bool power_on)
> > > return 1;
> > > }
> > > EXPORT_SYMBOL_GPL(acpi_dev_pm_attach);
> > > +
> > > +/**
> > > + * acpi_dev_low_power_state_probe - Tell if a device is in a low power state
> >
> > "Check the current ACPI power state of a device."
>
> Sounds good.
>
> >
> > > + * during probe
> >
> > Why is this limited to probe?
>
> Well.. that was the purpose. It could be used at other times, too, I guess,
> but most of the time runtime PM is the right interface for doing that.

PM-runtime is a layer above this one.

It is mostly about the coordination between devices, reference
counting etc which this is about device power states.

> >
> > The function actually checks whether or not the ACPI power state of
> > the device is low-power at the call time (except that it is a bit racy
> > with respect to _set_power(), so it may not work as expected if called
> > in parallel with that one).
> >
> > Maybe drop the "probe" part of the name (actually, I would call this
> > function acpi_dev_state_low_power()) and add a paragraph about the
> > potential race with _set_power() to the description?
>
> Agreed, I'll use the text you provided below.
>
> >
> > > + * @dev: The device
> >
> > "Physical device the ACPI power state of which to check".
>
> Ok.
>
> >
> > > + *
> > > + * Tell whether a given device is in a low power state during the driver's probe
> > > + * or remove operation.
> > > + *
> > > + * Drivers of devices on certain busses such as Iæ can generally assume (on
> > > + * ACPI based systems) that the devices they control are powered on without
> > > + * driver having to do anything about it. Using struct
> > > + * device_driver.probe_low_power and "probe-low-power" property, this can be
> > > + * negated and the driver has full control of the device power management.
> >
> > The above information belongs somewhere else in my view.
>
> How about putting it to the DSD ReST property documentation, perhaps with a
> little bit more context? I can add another patch for that.

Yes, something like that.