Re: [PATCH 1/4] media: rockchip/rga: add rk3228-rga to rockchip_rga_match[]

From: Justin Swartz
Date: Tue Jan 21 2020 - 06:51:35 EST


Hi Ezequiel,

On 2020-01-21 12:45, Ezequiel Garcia wrote:

On Mon, 2020-01-20 at 19:41 +0000, Justin Swartz wrote:

Add an entry to the rockchip_rga_match array for "rockchip,rk3228-rga"

Signed-off-by: Justin Swartz <justin.swartz@xxxxxxxxxxxxxxxx>
---
drivers/media/platform/rockchip/rga/rga.c | 3 +++
1 file changed, 3 insertions(+)

diff --git a/drivers/media/platform/rockchip/rga/rga.c b/drivers/media/platform/rockchip/rga/rga.c
index e9ff12b6b..268116cd5 100644
--- a/drivers/media/platform/rockchip/rga/rga.c
+++ b/drivers/media/platform/rockchip/rga/rga.c
@@ -956,6 +956,9 @@ static const struct dev_pm_ops rga_pm = {

static const struct of_device_id rockchip_rga_match[] = {
{
+ .compatible = "rockchip,rk3228-rga",
+ },

Unless you need to tune something in the driver
specifically for rk3228, then you don't need a
new compatible string.

As the name implies, it's just a "compatible",
so you may simply declare your rga dts node as
compatible to "rockchip,rk3288-rga".

(Of course, this means we shouldn't have added
the rk3399 compatible string.)

Thank you for the clarification.