Re: [PATCH] tcp: Use REXMIT_NEW instead of 2

From: Neal Cardwell
Date: Fri Jan 17 2020 - 09:29:01 EST


On Fri, Jan 17, 2020 at 5:04 AM Pengcheng Yang <yangpc@xxxxxxxxxx> wrote:
>
> Use REXMIT_NEW instead of the confusing 2 in tcp_xmit_recovery()
>
> Signed-off-by: Pengcheng Yang <yangpc@xxxxxxxxxx>
> ---
> net/ipv4/tcp_input.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/net/ipv4/tcp_input.c b/net/ipv4/tcp_input.c
> index 5347ab2..de07439 100644
> --- a/net/ipv4/tcp_input.c
> +++ b/net/ipv4/tcp_input.c
> @@ -3554,7 +3554,7 @@ static void tcp_xmit_recovery(struct sock *sk, int rexmit)
> if (rexmit == REXMIT_NONE || sk->sk_state == TCP_SYN_SENT)
> return;
>
> - if (unlikely(rexmit == 2)) {
> + if (unlikely(rexmit == REXMIT_NEW)) {
> __tcp_push_pending_frames(sk, tcp_current_mss(sk),
> TCP_NAGLE_OFF);
> if (after(tp->snd_nxt, tp->high_seq))
> --

This change was already made recently in the net-next branch (see
below). To avoid duplicate work like this, please submit improvement
patches like this as patches against the very latest net-next branch
(or net branch, for bug fixes).

thanks,
neal

--

commit d0e8bcafc8aff5553beffe55046795f9bab9fe7b
Author: Mao Wenan <maowenan@xxxxxxxxxx>
Date: Thu Jan 2 22:02:27 2020 +0800

tcp: use REXMIT_NEW instead of magic number

REXMIT_NEW is a macro for "FRTO-style
transmit of unsent/new packets", this patch
makes it more readable.

Signed-off-by: Mao Wenan <maowenan@xxxxxxxxxx>
Acked-by: Neal Cardwell <ncardwell@xxxxxxxxxx>
Signed-off-by: David S. Miller <davem@xxxxxxxxxxxxx>

diff --git a/net/ipv4/tcp_input.c b/net/ipv4/tcp_input.c
index 88b987ca9ebb..1d1e3493965f 100644
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
@@ -3550,7 +3550,7 @@ static void tcp_xmit_recovery(struct sock *sk, int rexmit)
if (rexmit == REXMIT_NONE || sk->sk_state == TCP_SYN_SENT)
return;

- if (unlikely(rexmit == 2)) {
+ if (unlikely(rexmit == REXMIT_NEW)) {
__tcp_push_pending_frames(sk, tcp_current_mss(sk),
TCP_NAGLE_OFF);
if (after(tp->snd_nxt, tp->high_seq))