Re: [PATCH 1/2] arm64: dts: qcom: sc7180: Add critical interrupt and cooling maps for TSENS in SC7180.

From: Amit Kucheria
Date: Wed Jan 01 2020 - 16:08:46 EST


On Mon, Dec 23, 2019 at 6:46 PM Rajeshwari <rkambl@xxxxxxxxxxxxxx> wrote:
>
> Signed-off-by: Rajeshwari <rkambl@xxxxxxxxxxxxxx>
> ---
> arch/arm64/boot/dts/qcom/sc7180.dtsi | 289 +++++++++++++++++++++++++++++------
> 1 file changed, 239 insertions(+), 50 deletions(-)
>
> diff --git a/arch/arm64/boot/dts/qcom/sc7180.dtsi b/arch/arm64/boot/dts/qcom/sc7180.dtsi
> index 3676bfd..e419ca0 100644
> --- a/arch/arm64/boot/dts/qcom/sc7180.dtsi
> +++ b/arch/arm64/boot/dts/qcom/sc7180.dtsi
> @@ -10,6 +10,7 @@
> #include <dt-bindings/interrupt-controller/arm-gic.h>
> #include <dt-bindings/phy/phy-qcom-qusb2.h>
> #include <dt-bindings/soc/qcom,rpmh-rsc.h>
> +#include <dt-bindings/thermal/thermal.h>


<snip>

> - cpu1-thermal {
> + cpu_0_1-thermal {

Is this renaming to include the cluster number really improving
anything considering that the cpus section defines them as CPU0..CPU7?

Leave them as-is.

> polling-delay-passive = <250>;
> polling-delay = <1000>;
>
> thermal-sensors = <&tsens0 2>;
>
> trips {
> - cpu1_alert0: trip-point0 {
> + cpu_0_1_alert0: trip-point0 {

cpu_0_1_alert0 is unnecessarily too long, IMO. Leave it as-is. Same
for all the renames below.

> temperature = <90000>;
> hysteresis = <2000>;
> type = "passive";
> };
>
> - cpu1_alert1: trip-point1 {
> + cpu_0_1_alert1: trip-point1 {
> temperature = <95000>;
> hysteresis = <2000>;
> type = "passive";
> };
>
> - cpu1_crit: cpu_crit {
> + cpu_0_1_crit: cpu_crit {
> temperature = <110000>;
> hysteresis = <1000>;
> type = "critical";
> };
> };

<snip>