Re: [PATCH 02/11] gpiolib: introduce devm_fwnode_gpiod_get_index()

From: Andy Shevchenko
Date: Wed Sep 11 2019 - 13:01:45 EST


On Wed, Sep 11, 2019 at 12:52:06AM -0700, Dmitry Torokhov wrote:
> devm_fwnode_get_index_gpiod_from_child() is too long, besides the fwnode
> in question does not have to be a child of device node. Let's rename it
> to devm_fwnode_gpiod_get_index() and keep the old name for compatibility
> for now.
>
> Also let's add a devm_fwnode_gpiod_get() wrapper as majority of the
> callers need a single GPIO.

> + return devm_fwnode_gpiod_get_index(dev, fwnode, con_id, 0,
> + flags, label);

At least one parameter can fit previous line, but taking into consideration
that moving second one makes it 81 character long, I would do it completely on
one line. I don't remember Linus' preferences.

> +}

> + return devm_fwnode_gpiod_get_index(dev, child, con_id, index,
> + flags, label);

Ditto.

--
With Best Regards,
Andy Shevchenko