[PATCH v2 0/3] mm/gup: introduce vaddr_pin_pages_remote(), FOLL_PIN

From: John Hubbard
Date: Wed Aug 21 2019 - 00:07:39 EST


Hi Ira,

This is for your tree. I'm dropping the RFC because this aspect is
starting to firm up pretty well.

I've moved FOLL_PIN inside the vaddr_pin_*() routines, and moved
FOLL_LONGTERM outside, based on our recent discussions. This is
documented pretty well within the patches.

Note that there are a lot of references in comments and commit
logs, to vaddr_pin_pages(). We'll want to catch all of those if
we rename that. I am pushing pretty hard to rename it to
vaddr_pin_user_pages().

v1 of this may be found here:
https://lore.kernel.org/r/20190812015044.26176-1-jhubbard@xxxxxxxxxx

John Hubbard (3):
For Ira: tiny formatting tweak to kerneldoc
mm/gup: introduce FOLL_PIN flag for get_user_pages()
mm/gup: introduce vaddr_pin_pages_remote(), and invoke it

drivers/infiniband/core/umem.c | 1 +
include/linux/mm.h | 61 ++++++++++++++++++++++++++++++----
mm/gup.c | 40 ++++++++++++++++++++--
mm/process_vm_access.c | 23 +++++++------
4 files changed, 106 insertions(+), 19 deletions(-)

--
2.22.1