Re: [PATCH 2/4] x86/vmware: Add a header file for hypercall definitions
From: Peter Zijlstra
Date: Tue Aug 20 2019 - 07:32:15 EST
On Sun, Aug 18, 2019 at 04:33:14PM +0200, Thomas Hellström (VMware) wrote:
> +#define VMWARE_HYPERCALL \
> + ALTERNATIVE_2(".byte 0xed", \
> + ".byte 0x0f, 0x01, 0xc1", X86_FEATURE_VMW_VMCALL, \
> + ".byte 0x0f, 0x01, 0xd9", X86_FEATURE_VMW_VMMCALL)
For sanity, could we either add comments, or macros for those
instrucions?
Something like:
#define INSN_INL 0xed
#define INSN_VMCALL 0x0f,0x01,0xc1
#define INSN_VMMCALL 0x0f,0x01,0xd9
#define VMWARE_HYPERCALL \
ALTERNATIVE_2(_ASM_MK_NOP(INSN_INL),
_ASM_MK_NOP(INSN_VMCALL), X86_FEATURE_VMCALL,
_ASM_MK_NOP(INSN_VMMCALL), X86_FEATURE_VMMCALL)
With possibly a patch that does 's/_ASM_MK_NOP/_ASM_MK_INSN/' on
arch/x86/ for further sanity :-)