Re: [PATCH v2 0/4] Simplify PCIe hotplug indicator control

From: Bjorn Helgaas
Date: Mon Aug 12 2019 - 16:02:58 EST


On Sun, Aug 11, 2019 at 10:59:40PM +0300, Denis Efremov wrote:
> PCIe defines two optional hotplug indicators: a Power indicator and an
> Attention indicator. Both are controlled by the same register, and each
> can be on, off or blinking. The current interfaces
> (pciehp_green_led_{on,off,blink}() and pciehp_set_attention_status()) are
> non-uniform and require two register writes in many cases where we could
> do one.
>
> This patchset introduces the new function pciehp_set_indicators(). It
> allows one to set two indicators with a single register write. All
> calls to previous interfaces (pciehp_green_led_* and
> pciehp_set_attention_status()) are replaced with a new one. Thus,
> the amount of duplicated code for setting indicators is reduced.
>
> Denis Efremov (4):
> PCI: pciehp: Add pciehp_set_indicators() to jointly set LED indicators
> PCI: pciehp: Switch LED indicators with a single write
> PCI: pciehp: Replace pciehp_set_attention_status()
> PCI: pciehp: Replace pciehp_green_led_{on,off,blink}()
>
> drivers/pci/hotplug/pciehp.h | 30 +++++++++++--
> drivers/pci/hotplug/pciehp_ctrl.c | 14 +++---
> drivers/pci/hotplug/pciehp_hpc.c | 74 +++++++++++--------------------
> include/uapi/linux/pci_regs.h | 2 +
> 4 files changed, 58 insertions(+), 62 deletions(-)

I really like these; thanks a lot for doing them. A few comments
later...