Re: [PATCH v3 3/5] locking/qspinlock: Introduce CNA into the slow path of qspinlock

From: Peter Zijlstra
Date: Wed Jul 17 2019 - 04:59:19 EST


On Wed, Jul 17, 2019 at 10:39:44AM +0200, Peter Zijlstra wrote:
> On Tue, Jul 16, 2019 at 08:47:24PM +0200, Peter Zijlstra wrote:

> > My primary concern was readability; I find the above suggestion much
> > more readable. Maybe it can be written differently; you'll have to play
> > around a bit.
>
> static void cna_splice_tail(struct cna_node *cn, struct cna_node *head, struct cna_node *tail)
> {
> struct cna_node *list;
>
> /* remove [head,tail] */
> WRITE_ONCE(cn->mcs.next, tail->mcs.next);
> tail->mcs.next = NULL;
>
> /* stick [head,tail] on the secondary list tail */
> if (cn->mcs.locked <= 1) {
> /* create secondary list */
> head->tail = tail;
> cn->mcs.locked = head->encoded_tail;
> } else {
> /* add to tail */
> list = (struct cna_node *)decode_tail(cn->mcs.locked);
> list->tail->next = head;
> list->tail = tail;
> }
> }
>
> static struct cna_node *cna_find_next(struct mcs_spinlock *node)
> {
> struct cna_node *cni, *cn = (struct cna_node *)node;
> struct cna_node *head, *tail = NULL;
>
> /* find any next lock from 'our' node */
> for (head = cni = (struct cna_node *)READ_ONCE(cn->mcs.next);
> cni && cni->node != cn->node;
> tail = cni, cni = (struct cna_node *)READ_ONCE(cni->mcs.next))
> ;

I think we can do away with those READ_ONCE()s, at this point those
pointers should be stable. But please double check.

> /* when found, splice any skipped locks onto the secondary list */
> if (cni && tail)
> cna_splice_tail(cn, head, tail);
>
> return cni;
> }
>
> How's that?