Re: [PATCH] rtc: zynqmp: One function call less in xlnx_rtc_alarm_irq_enable()

From: Alexandre Belloni
Date: Fri Jul 05 2019 - 18:36:25 EST


On 05/07/2019 22:45:39+0200, Markus Elfring wrote:
> From: Markus Elfring <elfring@xxxxxxxxxxxxxxxxxxxxx>
> Date: Fri, 5 Jul 2019 22:37:58 +0200
>
> Avoid an extra function call by using a ternary operator instead of
> a conditional statement for a setting selection.
>

Please elaborate on why this is a good thing.

> This issue was detected by using the Coccinelle software.
>

Unless you use an upstream coccinelle script or you share the one you
are using, this is not a useful information.

> Signed-off-by: Markus Elfring <elfring@xxxxxxxxxxxxxxxxxxxxx>
> ---
> drivers/rtc/rtc-zynqmp.c | 7 ++-----
> 1 file changed, 2 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/rtc/rtc-zynqmp.c b/drivers/rtc/rtc-zynqmp.c
> index 00639594de0c..4631019a54e2 100644
> --- a/drivers/rtc/rtc-zynqmp.c
> +++ b/drivers/rtc/rtc-zynqmp.c
> @@ -124,11 +124,8 @@ static int xlnx_rtc_alarm_irq_enable(struct device *dev, u32 enabled)
> {
> struct xlnx_rtc_dev *xrtcdev = dev_get_drvdata(dev);
>
> - if (enabled)
> - writel(RTC_INT_ALRM, xrtcdev->reg_base + RTC_INT_EN);
> - else
> - writel(RTC_INT_ALRM, xrtcdev->reg_base + RTC_INT_DIS);
> -
> + writel(RTC_INT_ALRM,
> + xrtcdev->reg_base + (enabled ? RTC_INT_EN : RTC_INT_DIS));

This makes the code less readable.

> return 0;
> }
>
> --
> 2.22.0
>

--
Alexandre Belloni, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com