[PATCH v3 0/1] mm/vmalloc.c: improve readability and rewrite vmap_area

From: Pengfei Li
Date: Thu Jul 04 2019 - 09:31:04 EST


v2 -> v3:
* patch 1-4: Abandoned
* patch 5:
- Eliminate "flags" (suggested by Uladzislau Rezki)
- Based on https://lkml.org/lkml/2019/6/6/455
and https://lkml.org/lkml/2019/7/3/661

v1 -> v2:
* patch 3: Rename __find_vmap_area to __search_va_in_busy_tree
instead of __search_va_from_busy_tree.
* patch 5: Add motivation and necessary test data to the commit
message.
* patch 5: Let va->flags use only some low bits of va_start
instead of completely overwriting va_start.

The current implementation of struct vmap_area wasted space.

After applying this commit, sizeof(struct vmap_area) has been
reduced from 11 words to 8 words.

Pengfei Li (1):
Modify struct vmap_area to reduce its size

include/linux/vmalloc.h | 20 +++++++++++++-------
mm/vmalloc.c | 24 ++++++++++--------------
2 files changed, 23 insertions(+), 21 deletions(-)

--
2.21.0