Re: [PATCH] remoteproc: Use struct_size() helper

From: Bjorn Andersson
Date: Sat Jun 29 2019 - 15:06:57 EST


On Fri 07 Jun 11:53 PDT 2019, Gustavo A. R. Silva wrote:

> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct resource_table {
> ...
> u32 offset[0];
> } __packed;
>
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
>
> So, replace the following form:
>
> table->num * sizeof(table->offset[0]) + sizeof(struct resource_table)
>
> with:
>
> struct_size(table, offset, table->num)
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx>

Looks good, applied

Thanks,
Bjorn

> ---
> drivers/remoteproc/remoteproc_elf_loader.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/remoteproc/remoteproc_elf_loader.c b/drivers/remoteproc/remoteproc_elf_loader.c
> index 215a4400f21e..606aae166eba 100644
> --- a/drivers/remoteproc/remoteproc_elf_loader.c
> +++ b/drivers/remoteproc/remoteproc_elf_loader.c
> @@ -247,8 +247,7 @@ find_table(struct device *dev, struct elf32_hdr *ehdr, size_t fw_size)
> }
>
> /* make sure the offsets array isn't truncated */
> - if (table->num * sizeof(table->offset[0]) +
> - sizeof(struct resource_table) > size) {
> + if (struct_size(table, offset, table->num) > size) {
> dev_err(dev, "resource table incomplete\n");
> return NULL;
> }
> --
> 2.21.0
>