[PATCH v4 0/2] drm/panfrost: drm_gem_map_offset() helper

From: Steven Price
Date: Thu Jun 27 2019 - 11:53:29 EST


Panfrost has a re-implementation of drm_gem_dumb_map_offset() with an
extra bug regarding the handling of imported buffers. However we don't
really want Panfrost calling _dumb functions because it's not a KMS
driver.

This series renames drm_gem_dumb_map_offset() to drop the '_dumb' and
updates Panfrost to use it rather than it's own implementation.

Previous versions:

v3: https://lore.kernel.org/lkml/20190520092306.27633-1-steven.price@xxxxxxx
Changes since v3:
* Add a comment to drm_gem_map_offset() explaining that it can be used
with shmem clients as well as dumb clients.

v2: https://lore.kernel.org/lkml/20190516141447.46839-1-steven.price@xxxxxxx/
Changes since v2:
* Drop the shmem helper

v1: https://lore.kernel.org/lkml/20190513143244.16478-1-steven.price@xxxxxxx/
Changes since v1:
* Rename drm_gem_dumb_map_offset to drop _dumb
* Add a shmem helper

Steven Price (2):
drm/gem: Rename drm_gem_dumb_map_offset() to drm_gem_map_offset()
drm/panfrost: Use drm_gem_map_offset()

drivers/gpu/drm/drm_dumb_buffers.c | 4 ++--
drivers/gpu/drm/drm_gem.c | 9 ++++++---
drivers/gpu/drm/exynos/exynos_drm_gem.c | 3 +--
drivers/gpu/drm/panfrost/panfrost_drv.c | 16 ++--------------
include/drm/drm_gem.h | 4 ++--
5 files changed, 13 insertions(+), 23 deletions(-)

--
2.20.1