Re: [PATCH v1 5/6] ASoC: Define a set of DAPM pre/post-up events

From: Marcel Ziswiler
Date: Thu Jun 13 2019 - 11:57:35 EST


On Tue, 2019-05-21 at 13:36 +0300, Oleksandr Suvorov wrote:
> Prepare to use SND_SOC_DAPM_PRE_POST_PMU definition to
> reduce coming code size and make it more readable.
>
> Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@xxxxxxxxxxx>

Reviewed-by: Marcel Ziswiler <marcel.ziswiler@xxxxxxxxxxx>

> ---
>
> include/sound/soc-dapm.h | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git include/sound/soc-dapm.h include/sound/soc-dapm.h
> index c00a0b8ade08..6c6694160130 100644
> --- include/sound/soc-dapm.h
> +++ include/sound/soc-dapm.h
> @@ -353,6 +353,8 @@ struct device;
> #define SND_SOC_DAPM_WILL_PMD 0x80 /* called at start of
> sequence */
> #define SND_SOC_DAPM_PRE_POST_PMD \
> (SND_SOC_DAPM_PRE_PMD |
> SND_SOC_DAPM_POST_PMD)
> +#define SND_SOC_DAPM_PRE_POST_PMU \
> + (SND_SOC_DAPM_PRE_PMU |
> SND_SOC_DAPM_POST_PMU)
>
> /* convenience event type detection */
> #define SND_SOC_DAPM_EVENT_ON(e) \
> --
> 2.20.1